LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   service could not start (https://www.linuxquestions.org/questions/linux-newbie-8/service-could-not-start-222526/)

LinuxRam 08-26-2004 02:08 AM

service could not start
 
when i tried to start my dhcpd service

#/etc/init.d/dhcpd status

no output

#/etc/inid.d/dhcpd start

no output

??

i am using redhat 8.0 and dhcp package is installed.

myriad-zero 08-26-2004 02:57 AM

You have to configure the DHCP server before starting it. By default, it is not configured. You have to edit dhcpd.conf and start DHCP server. For more info 'man dhcpd.conf' or http://man.linuxquestions.org/index....ction=0&type=2

LinuxRam 08-26-2004 04:04 AM

I tried to configure dhcp.conf file:

#cat /etc/dhcp.conf

default-lease-time 21600;
max-lease-time 21600;

option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;
#option domain-name-servers 192.168.1.4;
option domain-name "mandrake";
option root-path "192.168.1.55:/opt/ltsp/i386";


shared-network WORKSTATIONS
{
subnet 192.168.1.1 netmask 255.255.255.0
{}
}

group
{
use-host-decl-names on;

host ws001
{
hardware ethernet 00:C0:26:62:C5:96;
fixed-address 192.168.1.9;
filename "/ltsp/vmlinuz.ltsp";
}
}


I am trying to configure LTSP server for that i need dhcp service should start.

but still it doesn't starts even after configuring dhcp.conf file.

Plz have a look on the above file for any errors. and any idea to start dhcp service.

myriad-zero 08-26-2004 04:16 AM

Quote:

#cat /etc/dhcp.conf
Note that it is not dhcp.conf but dhcpd.conf

Try renaming the file and then start the service.

LinuxRam 08-26-2004 06:03 AM

thanks but,
 
thanks it started giving some message but,

it is failed while starting dhcpd.

plz have a look on dhcpd.conf file for any errors.


All times are GMT -5. The time now is 07:38 AM.