LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-29-2010, 08:32 AM   #1
jm21
LQ Newbie
 
Registered: Jul 2010
Posts: 1

Rep: Reputation: 0
Servfail problems


Hi. Am a linux newbie and I've been forced to setup a dns server on centos as the sys admin is away. I've installed Bind with chroot and its working fine, however I cant seem to get my domain to work. Below is the configuration

##named.conf

options {
directory "/var/named";
};

zone "axisha.com" IN {
type master;
file "/var/named/axisha.com.zone";
allow-update {none;};
};

zone "41.172.209.in-addr.arpa" IN {
type master;
file "/var/named/41.172.209.rev";
allow-update {none;};
};


conf for ##axisha.com.zone


$TTL 86400
@ IN SOA ns1.axisha.com. admin.axisha.com. (
2010072902 ; serial
3H ; refresh
15M ; retry
1W ; expiry
1D ) ; minimum
IN NS ns1.axisha.com.
ns1 IN A 209.172.41.202
ns2 IN A 209.172.41.200


conf for ##41.172.209.rev


$TTL 86400
@ IN SOA ns1.axisha.com. admin.axisha.com. (
2010072901 ; serial
3H ; refresh
15M ; retry
1W ; expiry
1D ) ; minimum
IN NS ns1.axisha.com.
ns1 IN A 209.172.41.202



when i do dig this is what i get

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> axisha.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 45107
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;axisha.com. IN A

;; Query time: 49 msec
;; SERVER: 209.172.41.202#53(209.172.41.202)
;; WHEN: Thu Jul 29 08:30:44 2010
;; MSG SIZE rcvd: 28

my resolv.conf has the following entries:
search axisha.com
nameserver 209.172.41.202
namserver 209.172.41.200



Any idea what am doing wrong? I've been at it for a couple of days and am getting nowhere. I get no error messages when i to tail /var/log/messages...but nothing works. Help!
 
Old 07-29-2010, 08:59 AM   #2
sem007
Member
 
Registered: Nov 2006
Distribution: RHEL, CentOS, Debian Lenny, Ubuntu
Posts: 638

Rep: Reputation: 113Reputation: 113
Quote:
conf for ##41.172.209.rev


$TTL 86400
@ IN SOA ns1.axisha.com. admin.axisha.com. (
2010072901 ; serial
3H ; refresh
15M ; retry
1W ; expiry
1D ) ; minimum
IN NS ns1.axisha.com.
ns1 IN A 209.172.41.202
In reverse zone use PTR record instead of A record.

use below command to check named configuration

Code:
named-checkconf path of named.conf
named-checkzone domainname path of forwardzone file
named-checkzone ipaddress path of forwardzone file
check these...
configure bind on centos

configuring DNS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
server can't find example.com: SERVFAIL redhat user Linux - Server 1 05-29-2009 04:42 PM
rhel5 in vmware gives servfail when dig zmagler Red Hat 0 12-16-2008 04:16 PM
Dns not working (servfail) Deepak Gusain Red Hat 2 12-11-2007 04:52 AM
NAMED (SERVFAIL message) overlord73 Linux - Software 1 01-31-2006 12:29 AM
2(SERVFAIL) error? GraemeK Linux - Networking 7 08-21-2003 12:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration