LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Server admin passed away... Help! (https://www.linuxquestions.org/questions/linux-newbie-8/server-admin-passed-away-help-4175602584/)

Jay1969 08-03-2017 06:21 PM

Anyone?

rknichols 08-03-2017 09:03 PM

I've been staying out of this because I don't know squat about ProxMox, but your "rsync -avcz /externalhdd/vzdump-qemu-100-2017_04_02-07_46_38.vma.lzo" command didn't copy anything because you didn't give it a destination argument. With just one argument, rsync just lists the source. Add the "/var/lib/vzbackup" (and, presumably, "--progress") arguments as originally instructed, and it should work.

Jay1969 08-05-2017 11:04 AM

2 Attachment(s)
Thanks very much for your input, rknichols!

I did relaunch the proper command but I get an insufficient disk space error (see attached). I used a 1 TB WD Green.

Reinstalled PM on a 2 TB WD Green... Unable to mount folder/device. Since I have copied the VMs to two XHDD, I shutdown PM to swap the XHDDs, retried to mount the device, and get the very same error message. See screenshot attached.

Reinstalled PM on a 4 TB WD Black... Still unable to mount folder/device using any one of both XHDDs.

Reinstalled PM on a 4 TB Seagate Barracuda... Still unable to mount folder/device using any one of both XHDDs.

Bottom line is that I am unable to mount the device on a HD with a bigger capacity than 1 TB. I am pretty confused here.

Are there any other ways to mount the folder in order to access the .lzo?

Any comments and ideas would be greatly appreciated.

rknichols 08-05-2017 02:10 PM

You just have to create the mount point directory first.
Code:

mkdir /externalhdd
mount /dev/sdb1 /externalhdd

It's always worthwhile checking whether you have enough space at the destination before startng a lengthy operation. Run "df -k /var/lib/vzbackup". The sizes will be in units of 1024 bytes, so multiply the shown available space by 1024 and make sure that is larger than the size that "ls -l /externalhdd/vzdump-qemu-100-2017_04_02-07_46_38.vma.lzo" shows for that file.

Jay1969 08-08-2017 06:33 AM

5 Attachment(s)
Thanks, rknichols.

I was able to mount the directory. I tried to copy the .lzo on the 2 TB HD with no luck. I got the same error message as not having sufficient disk space. See attached.

I tried to copy the .lzo on one of the 4 TB HD with no luck either, receiving the same darn message. I then was able to copy a previous backup, smaller in size. I suppose I can reasonably assume at this point that the backup I tried to copy since day one is corrupted... See attached.

Went back to PM console to add the folder, which remains empty. Snapshots are attached.

Any ideas?

pan64 08-08-2017 07:37 AM

rsync does not care about the content, so it is irrelevant (if that file was corrupted).
You can try:
Code:

du -h /externalhdd/vzdump-qemu-100-2017_04_02-07_46_38.vma.lzo
df -h /var/lib/vzbackup
df -i /var/lib/vzbackup

The size of the HDD is not important too, you need to check if there was enough space on the filesystem (that is the df command)

rknichols 08-08-2017 09:11 AM

You are trying to copy a 300+ GB file to a filesystem that is only ~101 GB total size with not quite 95 GB free. Of course it's not going to fit.

I presume that when you say, "I tried to copy the .lzo on the 2 TB HD," you mean that you tried to copy the file "onto" or "to" the 2TB drive. Just where is this 2TB (or 4TB) drive in this picture? All I'm seeing is a 101 GB filesystem.

Jay1969 10-30-2017 05:27 AM

As a simple courtesy, I am writing to close this post.

After having lost weeks if not months trying to get a grasp of ProxMox and Linux, I abdicated. We purchased a brand new HP server running W2016 Hyper-V and Veeam Backup & Replication a GUI!

We made an image of the existing W2012 VM with Veeam Endpoint in order to migrate it to the new server.

Simple, effective, user-friendly, but not cheap...

Still, happy camper! We are now able to focus on running the business instead of playing tech support.

Thanks to all of you who took the time to guide me and answer my questions. I just could not get my head around Linux, I guess.

Best,
Jay


All times are GMT -5. The time now is 03:39 AM.