-   Linux - Newbie (
-   -   sendmail not sending files to a particular domain (

Majed17 03-20-2013 08:17 AM

sendmail not sending files to a particular domain
Hello, i have a weird problem with sendmail.. i can send emails to the domain but not to
knowing that is where sendmail is contained.
here is the log file message:

Mar 20 16:06:20 srvmon-kozlova sm-mta[19215]: r2KD6HD0019215: to=<>, ctladdr=<> (0/0), delay=00:00:03, xdelay=00:00:03, mailer=esmtp, pri=30372, [], dsn=2.0.0, stat=Sent (OK id=1UIIig-0008Km-IZ)
obviously this message made it.
here is the message for the message that didn't make it:

Mar 20 16:06:37 srvmon-kozlova sm-mta[19891]: r2KD6ZBM019891: to=<>, ctladdr=<> (0/0), delay=00:00:02, xdelay=00:00:02, mailer=esmtp, pri=30357, [], dsn=5.0.0, stat=Service unavailable
here is the sendmail configuration:

VERSIONID(`$Id:,v 1.2 2004/12/07 01:59:31 g2boojum Exp $')dnl
FEATURE(`access_db', `hash -T<TMPF> -o /etc/mail/access.db')dnl
DAEMON_OPTIONS(`Port=smtp, Name=MTA')dnl

not set as relay..
here is the hosts file configuration:

# IPv4 and IPv6 localhost aliases srvmon-kozlova localhost
::1                localhost srvmon-kozlova srvmon-kozlova
# Imaginary network.
#              myname
#              myfriend                mail.metz.local

knowing that if i rename the server to in the hosts file then it stops sending mail all together with dsn 5.0.0 error even to the profiland webhost. i'm begining to suspect that this is a white list issue with the domain in the server. or is there something to be added to the access file? thanks for any help.

chrism01 03-20-2013 07:17 PM

Code: [], dsn=5.0.0, stat=Service unavailable
says there's no mail server at that IP, or at least you can't reach that system on port 25 eg intervening firewall.
I'd start by trying to telnet to port 25 on that system and see what response you get.

Majed17 03-21-2013 12:33 AM

thanks for the reply..didn't think of this though it is unreachable, i guess they need to be contacted..i tried sending to moitor @ metz.local didn't work either because it is going through the same hoster.

srvmon-kozlova ~ # telnet
telnet: Unable to connect to remote host: Connection refused

Majed17 03-21-2013 03:25 AM

ahh i forgot to add port 25 to it , it does telnet...

srvmon-kozlova ~ # telnet 25
Connected to
Escape character is '^]'.
220 ESMTP 6.0.2 is glad to see you!
telnet> quit
Connection closed.

what else is there to try? thanks for the help

chrism01 03-21-2013 05:47 AM

The implication is that it was down at the time..

1. try sending email again & check the logs
2. contact the admin for the remote system

Majed17 03-21-2013 06:28 AM

well thanks for the reply..i retried..telnet works but email doesn't.. i tried sending an email to yahoo but got status dsn 4.0.0 status: differed which is atleast not dsn 5.0.0 so i tried to send an email to my lebanese email and it passed me this only means one thing.
the problem is with can be telneted but emails don't go through which means it is some kind of problem with them what ever that is.

All times are GMT -5. The time now is 04:21 AM.