-   Linux - Newbie (
-   -   sendmail broke after rh 9 upgrade (

heathpitts 06-17-2003 09:17 AM

sendmail broke after rh 9 upgrade
I had a perfectly working server using rh7. So seeing as it worked great, I upgraded it to rh9. I got everything working again except sendmail from outside the server.

I use this server for group email and have the users send email to username@mail.workgroup

the email clients check their email fine but when sending, it gives them the error cannot connect to server (this is using outlook express). It seems like relaying is turned off or something.

Can somebod help me configure this so it will send email to the local users on the machine. I do not want it to send anywhere else

jvannucci 06-17-2003 09:44 AM

Edit /etc/mail/ and comment out the line (add a leading 'dnl'):

dnl # The following causes sendmail to only listen on the IPv4 loopback address
dnl # and not on any other network devices. Remove the loopback
dnl # address restriction to accept email from the internet or intranet.
dnl #
dnl DAEMON_OPTIONS(`Port=smtp,Addr=, Name=MTA')dnl

I seem to recall that this didn't used to be the default, but I'm not sure. That may explain your confusion.

Don't forget to restart sendmail:

# service sendmail restart

heathpitts 06-17-2003 09:50 AM

so the dnl in front of it comments it out? I tried deleting this line but it still doesn't seem to work. Anything else I can try?

nuzzy 06-17-2003 10:08 AM

change the line to:

DAEMON_OPTIONS(`Port=smtp, Name=MTA')dnl

don't comment it out.

heathpitts 06-17-2003 10:15 AM

with or wothout the dnl in front of it?

nuzzy 06-17-2003 10:18 AM


jvannucci 06-17-2003 10:25 AM

Yes, dnl "comments it out". The real answer is that it tells the macro processor to delete the rest of the line. Same thing to you and me. And the trailing 'd' in my earlier post is just a paste error. Please ignore.

But, as I re-read this I think I've misled you. Later versions of sendmail have changed the layout of some of the config files - check out /etc/mail/access. It looks like relaying IS turned off, except for localhost by default.

nuzzy 06-17-2003 10:33 AM

heathpitts...a good GUI for sendmail configuring is a great app called webmin. You can find it at It lets you easily add relay hosts, masquerades, aliases, etc...

Of course it's always good to learn by command line as well ;)

heathpitts 06-17-2003 11:11 AM

I have tried webmin before and i sort of feel like I am cheating (lol). But when I do pull it up it says file is in a different location.

In the /etc/mail/access file how would i add the range - 254

just type in RELAY

nuzzy 06-17-2003 11:17 AM

yeah, but I hope you're only using 192.168 as an example. Anyone could set that IP up and use you as an open relay. You should use the actual IP range that you are masking.

nuzzy 06-17-2003 11:22 AM

did you also do anything to your hosts.allow or hosts.deny files?

heathpitts 06-17-2003 02:03 PM

It still will not work.

Sendmail is running and working. If I telnet to the machine from the command line to port 25 it will not connect if i connect from localhost port 25 it connects just fine

nuzzy 06-17-2003 02:17 PM

You're confusing me as you never answered the previous question. Is the 192.168 IP address an example or are you really using it?? If you're really using it, then that's your problem. You need to use the actual IP assigned by the ISP. I'm also assuming you have port 25 open on your firewall?

heathpitts 06-17-2003 03:39 PM

ok this is for a workgroup email server it does not send messages to any other servers just to the local machine accounts.

Looking_Lost 06-17-2003 04:13 PM

Is there any level of firewall running?

Can you ping the computer?

All times are GMT -5. The time now is 08:29 AM.