-   Linux - Newbie (
-   -   selfcheck request failed for AMANDA backup of Red Hat Enterprise Linux 4 (

koopa13 06-04-2010 06:58 PM

selfcheck request failed for AMANDA backup of Red Hat Enterprise Linux 4

I installed amanda on a client that uses Red Hat Enterprise Linux 4

When I do an amcheck from the server, I get this

Amanda Backup Client Hosts Check
WARNING: selfcheck request failed: recv error: Connection reset by peer
Client check: 1 host checked in 0.022 seconds. 1 problem found.

I am using bsdtcp. I get an ACK error if I switch the client to bsd authentication.

What should I do, how do I fix it?

I read that I should enter servers adress to hosts file in /etc/ directory?


choogendyk 06-05-2010 12:24 PM

start here:

when you've worked through that, provide details.

koopa13 06-09-2010 05:39 PM

I tried to telnet to port 10080. But I get:

telnet: connect to address Connection timed out
telnet: Unable to connect to remote host: Connection timed out

I checked the client log file in /var/log/messages:

execv( /usr/libexec/amanda/amandad ) failed: Exec format error (errno = 8)

Why is this happening?

choogendyk 06-10-2010 08:19 AM

Check the log files in /tmp/amanda/ for details. Hopefully, it's not some weird thing related to your other post. There should be a lot of detail in a number of directories and time stamped files in /tmp/amanda. Typically, you'll find fairly explicit error messages or at least a detailed enough context to identify where the error is. Just look at the time stamped files that match a specific failure event you are trying to work out.

All times are GMT -5. The time now is 05:58 PM.