LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-15-2019, 10:26 AM   #1
ultra99
Member
 
Registered: Aug 2004
Distribution: openSUSE Tumbleweed
Posts: 109

Rep: Reputation: 15
second monitor doesn't work with laptop lid closed


I have a laptop setup with 2 external monitors. Both monitors are daisy chained via DP and then to my laptop via USB-C.

I have setup in display setting to disable laptop display, Monitor 1 primary, Monitor 2 secondary. If I have my laptop's lid open, it's display is shut (normal), and both monitors work. As soon as I close the lid, Monitor 1 is the only one on. I go to display settings, I see Monitor 1 only, not the second at all.

Manjaro GNOME | kernel 5.0 and also tried with 4.20
AMD Ryzen 2500U cpu and Vega 8 gfx.
 
Old 03-15-2019, 05:21 PM   #2
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,783

Rep: Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397
Quote:
Originally Posted by ultra99 View Post
I have a laptop setup with 2 external monitors. Both monitors are daisy chained via DP and then to my laptop via USB-C.

I have setup in display setting to disable laptop display, Monitor 1 primary, Monitor 2 secondary. If I have my laptop's lid open, it's display is shut (normal), and both monitors work. As soon as I close the lid, Monitor 1 is the only one on. I go to display settings, I see Monitor 1 only, not the second at all.

Manjaro GNOME | kernel 5.0 and also tried with 4.20
AMD Ryzen 2500U cpu and Vega 8 gfx.
You might check.

Gnome systemd_logind has options to disable the interpretation of the switch.
I found it for ubuntu - and found it on Fedora. There may be some other options you might want to tweak as well.

https://askubuntu.com/questions/1084...ut-don-t-sleep

The file on Fedora was /etc/systemd/logind.conf. On Fedora the file is loaded with the options (commented out) that are supposed to be the default values.
 
Old 03-16-2019, 10:47 AM   #3
ultra99
Member
 
Registered: Aug 2004
Distribution: openSUSE Tumbleweed
Posts: 109

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jpollard View Post
You might check.

Gnome systemd_logind has options to disable the interpretation of the switch.
I found it for ubuntu - and found it on Fedora. There may be some other options you might want to tweak as well.

https://askubuntu.com/questions/1084...ut-don-t-sleep

The file on Fedora was /etc/systemd/logind.conf. On Fedora the file is loaded with the options (commented out) that are supposed to be the default values.
This is what I'm getting:
Code:
 sudo /etc/systemd/logind.conf
sudo: /etc/systemd/logind.conf: command not found
 
Old 03-17-2019, 05:14 AM   #4
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,783

Rep: Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397Reputation: 1397
Quote:
Originally Posted by ultra99 View Post
This is what I'm getting:
Code:
 sudo /etc/systemd/logind.conf
sudo: /etc/systemd/logind.conf: command not found
It is a configuration file. Not an executable. you edit it.

On my system it has:
Code:
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See logind.conf(5) for details.

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
#HandleLidSwitch=suspend
#HandleLidSwitchExternalPower=suspend
#HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#InhibitorsMax=8192
#SessionsMax=8192
There are three "HandelLidSwitch*" entries. I set them to "ignore".

You might change them one at a time to see if it does what you want.

Last edited by jpollard; 03-17-2019 at 05:16 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Fix Laptop Doesn’t Suspend After Lid is Closed on Ubuntu Linux LXer Syndicated Linux News 0 02-17-2018 04:40 AM
Suspend when laptop-lid is closed doesn't work for me on Debian rokyo Linux - Newbie 7 10-07-2012 06:06 PM
[SOLVED] Doesn't suspend when lid is closed in 13.37 enine Slackware 4 05-25-2011 02:30 AM
Docking Station + External Monitor with Laptop Lid Closed 0ddba11 Linux - Hardware 6 05-26-2010 04:56 PM
laptop lid won't shut off when closed houler Slackware 32 08-27-2005 11:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration