LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   SE Linux is preventing a Codec from Loading in Fedora 10 (https://www.linuxquestions.org/questions/linux-newbie-8/se-linux-is-preventing-a-codec-from-loading-in-fedora-10-a-771829/)

kuwaitikid 11-26-2009 11:24 PM

SE Linux is preventing a Codec from Loading in Fedora 10
 
I am running Fedora 10, and I have this problem where all the Codecs dont load for MPlayer (I want to watch streaming video from my country)
The error message I receive is:

SELinux is preventing mplayer from loading /usr/lib/codecs/drv3.so.6.0 which requires text relocation.

If someone could please help me to fix this it would be much appreciated.

JD50 11-26-2009 11:54 PM

I'd just disable selinux.

unSpawn 11-27-2009 12:25 AM

Quote:

Originally Posted by JD50 (Post 3771002)
I'd just disable selinux.

Yes, you probably would. I'd say please don't give that kind of "advice". If you don't know SE Linux I'd say read up on it or keep yourself from "answering".

To the OP:
The Fedora online documentation, Setroubleshoot(d), or whatever else Fedora uses these days should show you an informative message you can allow this by running:
Code:

chcon -t textrel_shlib_t /usr/lib/codecs/drv3.so.6.0
semanage fcontext -a -t textrel_shlib_t /usr/lib/codecs/drv3.so.6.0


kuwaitikid 11-27-2009 01:03 PM

I ran the commands you recommended and they fixed the problem. Thank you.

Quote:

Originally Posted by unSpawn (Post 3771026)
Yes, you probably would. I'd say please don't give that kind of "advice". If you don't know SE Linux I'd say read up on it or keep yourself from "answering".

To the OP:
The Fedora online documentation, Setroubleshoot(d), or whatever else Fedora uses these days should show you an informative message you can allow this by running:
Code:

chcon -t textrel_shlib_t /usr/lib/codecs/drv3.so.6.0
semanage fcontext -a -t textrel_shlib_t /usr/lib/codecs/drv3.so.6.0




All times are GMT -5. The time now is 10:40 PM.