LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   SDL Error While Compiling... (https://www.linuxquestions.org/questions/linux-newbie-8/sdl-error-while-compiling-87774/)

Chryzmo 08-31-2003 07:58 PM

SDL Error While Compiling...
 
I tried to compile Openglad, a port of an old DOS game I believe, on my Mandrake 9.1 system. When I typed ./configure I got the following output.

checking for a BSD-compatible install... /usr//bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for g++... g++
checking for C++ compiler default output... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of g++... gcc3
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking dependency style of gcc... gcc3
checking whether make sets $(MAKE)... (cached) yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for sdl-config... no
checking for SDL - version >= 1.2.0... no
*** The sdl-config script installed by SDL could not be found
*** If SDL was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the SDL_CONFIG environment variable to the
*** full path to sdl-config.
configure: error: *** SDL version 1.2.0 not found!

I checked and I have SDL 1.2.5-5mdk installed, it was installed initially on the computer. I also tried installed SDL 1.2.6 from the SDL site, but immediatly got an error about it conflicting with SDL 1.2.5 so I gave up on upgrading SDL. I figured this verysion should work as it is newer than 1.2.0. Please Help...

Thanks,
Chryzmo

darthtux 09-01-2003 12:20 AM

You need to install the SDL-devel rpms - the ones you installed just contain runtime files, not development headers and libraries.


All times are GMT -5. The time now is 01:48 PM.