-   Linux - Newbie (
-   -   scrot reveals hidden desktop space...WTF?! (

zer010 04-14-2011 09:14 PM

scrot reveals hidden desktop space...WTF?!
2 Attachment(s)
I found this issue after trying to get my Conky up and running in Fedora 14(Xfce). Every time I started Conky, I would get nothing, but the default Conky would appear just fine.

Well, I was messing around with scrot and I noticed that the screenshot appears to show other workspaces or something to the right of my current desktop. So I figured I'd bring up the default Conky but I changed the orientation to top_right. I then took another screenshot and sure enough, there was the Conky in limbo.

Has anyone else experienced this? Is this an issue with Fedora, Xfce or something else?

Pictures are said to be worth 1000 words, so hopefully the pictures included will explain this issue better than I.

corp769 04-16-2011 12:15 AM

The only thing I can think of is how many instances of conky do you have running? Look at the output of "ps aux | grep conky" and see what comes up. If anything, you may have more than one instance of it running, and if so, at least two configs are trying to use the same desktop space. See what the output of that command gives you and try making sure that you only have one config running for now.


zer010 04-16-2011 06:02 AM

1 Attachment(s)
No, I'm certain that I only have one Conky running. WHenever I stop Conky, I'm using the killall command.

Ok, I just made a new discovery! Messing around with scrot again and I took a look at the resulting image and I noticed that the size of the picture is 1744x768. So I go to the monitor tool to see if that's one of the resolution options. It isn't. Just out of curiosity, I change the resolution from what should be 1024x768 to 800x600. Then I changed it back and when I started Conky, it was right where it was supposed to be! So I was wondering if this "fix" would stick, so I rebooted. Apparently, it doesn't stick after a reboot....

I'm thinking that I'm getting the wrong resolution at startup. Since Fedora 14 doesn't have a xorg.conf, I'll have to make one. I'm thinking that if I install the nvidia drivers, that should give me a new xorg.conf to work with.

corp769 04-16-2011 07:51 AM

Check that out; You just may need to do that then man. Hope that helps out,


zer010 04-16-2011 08:05 AM

I seen that and since system-config-display is no longer available in F14, I tried the second method, but came up with errors. I'd post the errors, but I'll have to boot into Fedora(I'm in Ubuntu right now). Either way, do you think that a set resolution in xorg.conf might solve this issue?

It still boggles me as to why Fedora doesn't create an xorg.conf file....

corp769 04-16-2011 09:15 AM

Well if anything, I would create it and mess with it to see if it even is a resolution problem.

MTK358 04-16-2011 09:25 AM


Originally Posted by zer010 (Post 4326226)
It still boggles me as to why Fedora doesn't create an xorg.conf file....

In most cases it causes more confusion than good for newbies.

X without xorg.conf always worked great for me, as long as there's only one monitor.

zer010 04-18-2011 01:06 AM

1 Attachment(s)
I figured out a temporary fix using xrandr at startup. ^.^d

corp769 04-18-2011 06:19 AM

That works too, glad to hear you you found a fix. :p

zer010 04-18-2011 02:41 PM


Originally Posted by corp769 (Post 4327815)
That works too, glad to hear you you found a fix. :p

If there's one thing that I love about Linux, it's flexibility that allows various issues to be solved in various ways.

All times are GMT -5. The time now is 07:17 AM.