Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 02-11-2009, 09:15 PM   #1
LQ Newbie
Registered: Oct 2008
Posts: 4

Rep: Reputation: 0
Screwed up screens during KDE 4 login


I've recently installed OpenSuse 11.1 with KDE 4, and in general it's been working great - except for a little problem which disturbs me a little. Several times both when opensuse is loading (with the bootsplash image showing) and after I key in my login credentials and KDE4 is loading (with the KDE 4 splash playing), I get flashes of these screwed up screens. They're completely unintelligible, and (though this may vary) usually consists of great black streaks slashing across the display.

I'm wondering if some of my display settings may be bad? After the KDE desktop actually loads, I have no problems. I am able to use desktop effects, and have my screen resolution up to the maximum supported by my laptop.

Any help/advice on the issue will be greatly appreciated
Old 02-11-2009, 09:49 PM   #2
Senior Member
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 480Reputation: 480Reputation: 480Reputation: 480Reputation: 480
yeap go to compiz-fuson and chech out there forum on the xorgsetup for you display card
Old 03-26-2009, 07:28 AM   #3
LQ Newbie
Registered: Mar 2009
Posts: 3

Rep: Reputation: 0
I had the same problem. I found 2 workarounds to fix it.

1)Go to Yast>System>Edit sysconfig. Go to Desktop>Display>at the bottom of the list somewhere is a KDM option...sorry I can't remember which on all of them and find the one which shows SUSE as the default written in the box on the left hand side. Delete it and type in oxygen.

Also you should for now....go to the kicker menu, find Configure desktop. If you are using KDE, go to Appearance and then sroll down to splash None.

Reboot and you will have no rendering errors at log in.

2)Go to Yast>System>Edit sysconfig. Go to Desktop>Display> Choose the item at the top of the list and type in kdm.

This works for me!

Good Luck!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Screwed up devpts won't let me login! dmorris68 Fedora 1 10-28-2004 08:40 AM
Multiple X login screens sbalasuriya Linux - General 3 04-29-2004 08:12 PM
HELP: Screwed up login screen! Cookie Linux - General 2 03-31-2004 10:51 AM
Mandrake Login screens Wynand1 Mandriva 1 03-20-2004 04:23 AM
How to change the login/logoff screens? mchitsquad Mandriva 2 03-16-2004 02:34 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:20 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration