LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-31-2009, 05:29 PM   #1
KlausG
LQ Newbie
 
Registered: May 2009
Posts: 4

Rep: Reputation: 0
screensaver doesn't work in Mint7


Hello,
coming from mint 6, i migrated successfully to Mint 7 (Gloria)
Great OS.
The only problem is that the screensaver will not activate itself.
I am using Gnome screensaver and it worked fine in Mint 6 with the same settings (afaik) as i am using now in Mint7.

It probably is a trivial thing, but can't figure it out. Has anyone any ideas or even the same problem?
Thx in advance.

KlausG
 
Old 05-31-2009, 06:36 PM   #2
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
What does
Code:
 gnome-screensaver-preferences
Do for you? This should bring up the configuration dialog. Also, try running
Code:
 gnome-screensaver
And see if you get the error message
Code:
jc@jcmain:~$ gnome-screensaver

** (gnome-screensaver:24789): WARNING **: screensaver already running in this session
 
Old 06-01-2009, 02:12 AM   #3
KlausG
LQ Newbie
 
Registered: May 2009
Posts: 4

Original Poster
Rep: Reputation: 0
screensaver doesn't work in Mint7

Thx for ur reply.
Yes, this is what i get as well.
But the interesting thing is that after i close firefox, the screensaver works fine. This was not the case in mint 6. There i could have left it open and the screensaver would have kicked in anyway.
In other words as long as the browser is open, the computer is not considered as being 'idle'? (where it says: “activate screensaver when computer is idle”)
Is this a bug in Mint7? (which i can hardly imagine, but anyway)
Any ideas?
Thx again.
Regards
KlausG
 
Old 06-01-2009, 05:20 AM   #4
rikxik
Member
 
Registered: Dec 2007
Posts: 88

Rep: Reputation: 19
Start firefox in safe mode:

Code:
firefox -safe-mode
This will start a firefox session with all add-ons disabled (temporarily). Just keep one single tab open (say, www.google.com). Then see if it makes any difference.

If your screensaver kicks-off, then the culprit is some add-on. Identify the issue by disabling them one by one and retrying.

If your screensaver stil refuses to kick-of, check $HOME/.xsession-errors (I can't remember the filename exactly).

You can also kick-off firefox with -console option for debugging info. Also check the /var/log/syslog & /var/log/messages + any gnome-screensaver specific logs (if any).

You may also want to find out if you can start gnome-screensaver with some debug flag on.

Can't think of anything else
 
Old 06-02-2009, 01:50 AM   #5
KlausG
LQ Newbie
 
Registered: May 2009
Posts: 4

Original Poster
Rep: Reputation: 0
thx alot for answering.
As a music lover i tend to have the webradio running in the background while i am working. The screensaver in Mint6 worked just fine while the application in FF was on, but in Mint7 that is not the case.
Apparently in Mint7 the computer is not being considered 'idle' while the webradio is on.
I found out by testing various possibilities. It's no real problem of course, but at least now i know that it doesn't concern a major flaw.
I still think Mint7 is a great OS.
Thx again.
regards
KlausG
 
Old 06-02-2009, 11:19 PM   #6
rikxik
Member
 
Registered: Dec 2007
Posts: 88

Rep: Reputation: 19
Good to know that you put in some effort in testing and isolated the issue and didn't just shout "Mint 7 is crap!!!"

I'm not sure if this issue qualifies as a bug - you may consider logging it as a bug report anyway (if only to get some feedback/wider opinion).
 
Old 06-04-2009, 03:20 AM   #7
KlausG
LQ Newbie
 
Registered: May 2009
Posts: 4

Original Poster
Rep: Reputation: 0
thx for ur recommendation and reply.
Someone else recently also mentioned the streaming 'problem'.
But honestly, i already feel like a nitpicker with this trivial item. Therefore i will not report it as a bug, the OS is too good to mention this as a real problem that needs to be fixed. If others read this topic (again) it maybe helpful as it is.
My workaround is initiating the 'preview' of the screensaver for as long as needed.
I am still glad having decided to use Linux. :-)

regards
KlausG
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Screensaver won't work (Redhat 8) Rimmer Linux - Distributions 14 03-18-2008 03:59 PM
screensaver doesnt work encore Slackware 10 09-21-2005 04:43 PM
screensaver password doesnt work doralsoral Linux - Software 1 07-13-2004 04:42 PM
screensaver wont work Longinus Linux - Newbie 1 02-18-2004 05:25 PM
KDE - screensaver doesn't work nigham Linux - Software 5 10-07-2003 09:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration