LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-29-2006, 01:09 PM   #1
epiphiny
LQ Newbie
 
Registered: Apr 2006
Posts: 7

Rep: Reputation: 0
Screen resolution wrong at every thirrd boot!


Hi there.

I've just installed FC5 on my IBM xSeries 206 eServer.

As I'm on a wireless network, I just installed my Netear WG111T wirless network adapter using Madwifi. However, during installation yum also updated my kernal to 2.6.16

The problem is that this kernal seems to hate my graphics card; every time I reboot, it fails to find the correct screen resolution, and so I get 'signal over range' appear on my monitor. If I pull the plug out and restart, I gat the same thing again. However, on the thrid reboot its all fine and dandy.

I've looked in my xorg.conf file, and it seems to be listing the correct resolutions, as well as the right hardware.

I've no idea why it fine again after every thrid boot; no files should change, should they?

uname -r is 2.6.16-1.2096_FC5

And the contents of my xorg.conf is;
Quote:
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, a font server independent of the X server is
# used to render fonts.
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "LCD Panel 1024x768"
DisplaySize 300 230
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 31.5 - 48.5
VertRefresh 40.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "radeon"
VendorName "Videocard vendor"
BoardName "ATI Technologies Inc RV280 [Radeon 9200 PRO]"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
Any advice would be greatly appreciated, thanks in advance

James
 
Old 04-29-2006, 02:09 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Shooting in the dark here (as probably most will since this is an intermittent problem) any chance you have conflicts with IRQ's and the videocard? Check in your server's BIOS to see if you can assign your Videocard it's own IRQ seperate from the others.

HTH

Cool
 
Old 04-30-2006, 11:53 AM   #3
epiphiny
LQ Newbie
 
Registered: Apr 2006
Posts: 7

Original Poster
Rep: Reputation: 0
Hi, thanks for the quick response.

I'd try that, however the problem has now got quite a bit worse, and now I can't seem to boot at all. Is there anyway I can stop xorg from starting at boot? I've done an interactive startup but it doesnt seem to ask me if I want to start x (I'm assuming that that would let me use the CLI to log in). Ill try another couple of reboots (I'm using windows at the moment),and try go check the IRQ's. If that doesnt work I'll try plugging it into my higher resolution monitor downstairs.

Thanks again for the quick response.
 
Old 04-30-2006, 12:23 PM   #4
epiphiny
LQ Newbie
 
Registered: Apr 2006
Posts: 7

Original Poster
Rep: Reputation: 0
ok, I finally got it to boot again by selecting my old kernel from GRUB (2.15.x). I've now rebooted again, and this time when I selected 2.16.x everything was fine! It seems to be a kernel problem, but I really cant understand which files are being changed at boot up!

Also, I can't find a way to change the IRQ of my videocard from BIOS, but I did try rebooting after removing the video card, and booting using my motherboards graphics chip; the problem remained.

Any other suggestions would be really appreciated, this is really starting to annoy me now!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 11:52 AM
desktop area larger than screen resolution (something wrong with X config?) amon Linux - General 5 03-16-2006 01:47 PM
X login screen uses wrong resolution with viewport donni Linux - Software 2 06-12-2005 11:57 AM
problem on boot because of wrong resolution julian_s Linux - Newbie 1 05-15-2004 11:02 PM
What the hell am I doing wrong? Blank screen on boot. yakko Linux - Newbie 13 06-02-2003 08:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration