LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   screen flashing when boot - trying to start X? (https://www.linuxquestions.org/questions/linux-newbie-8/screen-flashing-when-boot-trying-to-start-x-31728/)

rayne 10-02-2002 02:52 PM

screen flashing when boot - trying to start X?
 
Ok. I finally got my dual boot working. I still have to make a boot disk since the once I made during install doesn't work. Anyway, once in I get to the login prompt and the screen flashes. I think it is trying to start the GUI.

After a while of this annoyance I get this message:

INIT: x respawning too fast...disabled for 5 minutes

at which point I can use the command line fine till it starts up again. I'm guessing it has something to do with my X config, but not sure where to go from here.

Anyone have suggestions?

d3funct 10-02-2002 05:34 PM

Have you tried running Xconfigurator and reconfiguring X?

kmistry 10-02-2002 06:29 PM

please give basic system information pertaining to this subject
distro, video card, xfree version. etc.

rayne 10-02-2002 08:46 PM

I'm using Redhat 7.3 dual boot with Win2K. My video card is a 3DForce S-128 using an SIS315 chipset. I'm not sure how to configure this so that I can use the graphical. Even at the command line, the screen flashes.

I tried going into Xconfigurator and I chose unlisted card, because I couldn't find my card and chose the SVGA server. it said it couldn't find that server. I didn't get the option to choose a server when I tried to go in. I thought maybe I'd pick something else, but I'm not sure what I'm supposed to choose for my setting.

GT I.N.C 10-02-2002 09:15 PM

There should be support for that SIS315 chipset, have you tried probing your video card ?

rayne 10-02-2002 09:38 PM

I changed inittab so that I boot into runlevel 3 instead of 5. Maybe that will help the flashing, but starting X gives me a bunch of errors and a no screens found error.

How do I probe the video card?

rayne 10-03-2002 08:14 AM

OK. I ran Xconfigurator and selected a video card that I thought was a close match. it probed my monitor and chose the correct setting. But when it tried to probe the video card it said there was an error and I should configure it manually. So I did, choosing not clockset (or someting of that sort) which was listed as recommended. I chose my resolutions. It then said it was going to start X to test my settings. It said there was an error, but I could go back and edit my settings or skip it. I tried again and instead of testing it I went on and saved it. It said it had saved to XF86Config.

When I tried to start X I got the no screens found error, but the config file it said it was using was XF86Config-4. How do I get Xconfigurator to write to the -4 file instead of the other one? Or how do I config that version?

myg 10-08-2002 10:35 AM

I was installing 7.3 for a friend and had similar situation. Check if X server was installed. Wheneber I tried to run X in probe mode I was getting errors like "rgb" module is not found, kbd module is mission, etc. rpm package that containds X server was corrupted (hell knows how 1 file in iso gets corrupted)
After I got XFree86-4.xxxxx.rpm buy hand ond updated the package, evrything started working.
Just mount upir RH7.3 CD and try to upgrade rpm -U -vv XFree86-4.0.1??????.rpm and see what happens...


All times are GMT -5. The time now is 04:38 PM.