-   Linux - Newbie (
-   -   screen blanks halfway through boot but still responsive (

AAnarchYY 02-13-2008 06:41 PM

screen blanks halfway through boot but still responsive
System: Slackware 11, custom 2.6.22, lilo, P3 600Mhz, ATI Rage Mobility, i think its a dell latitude(lost the sticker)

Problems come at me in threes, I swear... I _just_ fixed a really ugly problem with the mbr and had to update the kernel(FATAL: kernel too old), fixed that... now it boots to the lilo menu, i select the kernel and it begins loading everything. problem is about two pages into the boot, the screen flickers and blanks, but contiunues to load. If i give it a few minutes for it to drop to the login prompt, i can blindly type my username and password, then startx, and poof! i have my desktop up. I dont know if that makes much sense, but i was wondering if anyone had anything like this happen to them and if they knew the solution. It sounds like a driver problem to me. Ive tried numerous vga= kernel options all with the same result. Thanks for reading this and hopefully having some insight into my dilema :)

bsdunix 02-13-2008 08:05 PM

It would be nice if you could remember a few lines of the boot screen before it goes blank, such is what is loading.

Any boot related errors in /var/log/messages?

Maybe a custom font problem? If you do use custom fonts, have you tried removing the exec bit on the rc.font file so it dosen't get loaded at boot?

Another thing you might want to check is the kernel configuration you used against what Pat used relating to console display? The Slackware current kernel is and the section is:

# Console display driver support
# CONFIG_FONT_6x11 is not set
# CONFIG_FONT_7x14 is not set
# CONFIG_FONT_PEARL_8x8 is not set
# CONFIG_FONT_ACORN_8x8 is not set
# CONFIG_FONT_MINI_4x6 is not set
# CONFIG_FONT_SUN8x16 is not set
# CONFIG_FONT_SUN12x22 is not set
# CONFIG_FONT_10x18 is not set
# CONFIG_LOGO_LINUX_VGA16 is not set

AAnarchYY 02-13-2008 08:33 PM

the text goes by waay to fast for me to be able to read any of it, but when i can finaly get it into X,i scrutinized the /var/log/messages file for _anything_ out of the ordinary, and couldnt find anything strange, No custom fonts. It almost looks like something borks up when its probed. I know its a kernel related problem, i just gotta figure out what it is that made it work before. Disaster recovery can be hell sometimes... The part that confuses me about it is that it starts to load and while everything is loading it flashes twice and stays blank, but continues to load; and i can make it startx, maybe its a wrong module or something...

Im going to go take a closer look at my kernel config.

H_TeXMeX_H 02-14-2008 03:23 AM

I see that you have custom kernel. I think you probably forgot to enable framebuffer support. But you can still boot without it by booting with the option 'vga=normal'.

All times are GMT -5. The time now is 03:13 AM.