LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-21-2010, 09:26 PM   #1
yijiaochen
LQ Newbie
 
Registered: Dec 2010
Posts: 2

Rep: Reputation: 0
Scientific Linux (SL)5.5 Shutting Down Problem


Hi all,
I have this SL 5.5 installed. But every time I try to shut down, it stops with 'acpi-power-off called'. I searched how to solve such problem, and is suggested to change 'grub.conf' and add 'acpi=off'. Here is detailed info. of my 'grub.conf'. Anyone can tell me where to add this 'acpi=off'? Thank you so much!
___________________________________________________
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Scientific Linux (2.6.18-194.3.1.el5)
root (hd0,0)
kernel /vmlinuz-2.6.18-194.3.1.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.18-194.3.1.el5.img
 
Old 12-21-2010, 09:31 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
You need the acpi if you want the computer to automatically turn off the power.

Either the acpi module isn't working or your motherboard has got acpi disabled.

Check your BIOS/CMOS settings on the motherboard. If acpi or apm is disabled then enable it.
 
Old 12-21-2010, 09:34 PM   #3
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: pclinuxos slackware64 tails kali
Posts: 3,372
Blog Entries: 33

Rep: Reputation: 217Reputation: 217Reputation: 217
Quote:
Hi, Welcome to LQ!

LQ has a fantastic search function that may save you time waiting for an answer to a popular question.

With over 4 million posts to search it's possible the answer has been given.
you may add the command at boot, or edit that grub file...

Quote:
kernel /vmlinuz-2.6.18-194.3.1.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
leave a space, and append...
Code:
kernel /vmlinuz-2.6.18-194.3.1.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=off
Or "noacpi" = "acpi=off"

Hope this helps,

Regards Glenn
 
Old 12-21-2010, 09:35 PM   #4
ubyt3m3
Member
 
Registered: Apr 2008
Distribution: Slackware64 13.37, Solaris 10, RHEL5/6
Posts: 92

Rep: Reputation: 19
it goes in the kernel line like this:

kernel /vmlinuz-2.6.18-194.3.1.el5 ro root=/dev/VolGroup00/LogVol00 rhgb acpi=off

-gibb

Last edited by ubyt3m3; 12-21-2010 at 09:38 PM. Reason: stress_junkie and GlennsPref beat me to it!
 
Old 12-21-2010, 09:39 PM   #5
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: pclinuxos slackware64 tails kali
Posts: 3,372
Blog Entries: 33

Rep: Reputation: 217Reputation: 217Reputation: 217
There's more here.

But check your bios first,
Quote:
[PDF]
Kernel Boot Command-Line Parameter Reference
File Format: PDF/Adobe Acrobat - Quick View
1 Dec 2006 ... different kernel boot command-line reference options, which were written ... built in to the kernel can also be passed on the command line. ...
http://www.kernel.org/pub/linux/kern...n_pdf/ch09.pdf
 
Old 12-21-2010, 10:18 PM   #6
yijiaochen
LQ Newbie
 
Registered: Dec 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by GlennsPref View Post
you may add the command at boot, or edit that grub file...



leave a space, and append...
Code:
kernel /vmlinuz-2.6.18-194.3.1.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet acpi=off
Or "noacpi" = "acpi=off"

Hope this helps,

Regards Glenn
Thanks Glenn,
I logged in as root, as I've got [Permission Denied] message when I tried to change 'grub.conf'.
cd /etc
vi grub.conf
Then change it according to your suggestion, it still did not work.
Did i change correctly?
 
Old 12-22-2010, 02:51 AM   #7
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: pclinuxos slackware64 tails kali
Posts: 3,372
Blog Entries: 33

Rep: Reputation: 217Reputation: 217Reputation: 217
as root, Maybe make a backup first,

cp /boot/grub/menu.lst /boot/grub/menu.lst.bak

edit this file, like you tried before.

vi /boot/grub/menu.lst

Regards Glenn

ps, I don't have a file, /etc/grub.conf, your system may differ....

But I have read '/boot/grub/menu.lst' being described as, the grub conf.

Last edited by GlennsPref; 12-22-2010 at 02:54 AM.
 
Old 12-22-2010, 02:57 AM   #8
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: pclinuxos slackware64 tails kali
Posts: 3,372
Blog Entries: 33

Rep: Reputation: 217Reputation: 217Reputation: 217
One thing to keep in mind with vi,

typing at a prompt,

vi /somefile

if the file does not exist, it will be created in memory.

When :wq to save the file and exit vi, the file is written to disk.

Cheers Glenn
 
Old 12-22-2010, 03:48 AM   #9
honeybadger
Member
 
Registered: Aug 2007
Location: India
Distribution: Slackware (mainly) and then a lot of others...
Posts: 855

Rep: Reputation: Disabled
If you just want to try 'acpid=off' you can go into the grub menu (when you have the grub screen) and then press 'e' to edit. Go down to the line that says kernel and then at the end add 'acpid=off' and then press 'b' to boot. Check if the shutdown works properly there.
If it does not work then we would look at BIOS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Scientific Linux (RH 5.3) Wi Fi Problem PrinceCruise Linux - General 2 10-21-2009 09:10 AM
Scientific Linux related problem in my laptop futoskope Linux - Newbie 2 09-25-2008 04:39 AM
Scientific Linux problem... futoskope Linux - Newbie 3 09-03-2008 07:05 AM
Problem installing Intel Graphics driver on Scientific Linux 5 [RHEL5] n-david Linux - Hardware 1 12-12-2007 08:55 AM
Problem with Xgl on Scientific Linux 5 mjollnir82 Red Hat 0 10-25-2007 02:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration