LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-01-2009, 05:06 PM   #1
yus-suf
LQ Newbie
 
Registered: Jun 2009
Posts: 7

Rep: Reputation: 0
school project help needed samba


hi evryone, hoping to get some help here

i'm working for a school project with all kinds of servers making it possible to synch with each other and i am gettin at the deadline and need to get this working fast :S, but anyways my problem is

that i can't get samba working on windows xp for some reason. i've been able to set up a samba server in the past, but this time its something i can't figure out.

i'm working with fedora 10 and with the samba package that came with it

i'm getting the message when i try to get in the public map directly or trying to map it
http://i15.photobucket.com/albums/a3...ty_/error1.jpg

my smbd.conf
Code:
[global]
workgroup = wrkgrp
netbios name = smbserver
security = SHARE
load printers = No
default service = global
path = sambashares
available = No
encrypt passwords = yes

[share]
writeable = yes
admin users = smbuser
path = sambashares/share
force user = root
valid users = smbuser
public = yes
available = yes

[public]
path = sambashares/public
public = yes
only guest = yes
writable = yes
printable = no
available = yes
Code:
adduser smbuser
passwd smbuser
smbpasswd -a smbuser
restarting service
Code:
/etc/init.d/smb status
and firewall is off

thnx for reading and trying to help

Last edited by yus-suf; 06-01-2009 at 05:17 PM.
 
Old 06-01-2009, 05:09 PM   #2
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
Any chance of just pasting/typing in future? Those links are annoying.

Basic gist of your problem, windows wont see the share? Or does it see it, but can't connect?
 
Old 06-01-2009, 05:15 PM   #3
yus-suf
LQ Newbie
 
Registered: Jun 2009
Posts: 7

Original Poster
Rep: Reputation: 0
ehm sorry for images, thought it would make it easier to understand

i tryed it again and now it says it can't find the networkpath
but when i type \\ip it shows me the maps i need
 
Old 06-01-2009, 05:18 PM   #4
jamescondron
Member
 
Registered: Jul 2007
Location: Scunthorpe, UK
Distribution: Ubuntu 8.10; Gentoo; Debian Lenny
Posts: 961

Rep: Reputation: 69
But to answer my question, what exactly is the problem? Where is the problem, which machine is the problem on, are you sure this is a linux question?
 
Old 06-01-2009, 05:25 PM   #5
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Try testparm to check your config.

You need absolute paths for the shares (ie leading /).

Is your server firewall open for the relevant samba ports? See http://us3.samba.org/samba/docs/man/...#firewallports
 
Old 06-01-2009, 05:27 PM   #6
yus-suf
LQ Newbie
 
Registered: Jun 2009
Posts: 7

Original Poster
Rep: Reputation: 0
i think it is a linux problem

i turned off firewall on windows and on linux and it has the same ip and all but still won't work.
i think it has something to do with acces permissions

i already changed the directory user/group/chmod to smbuser

edit:
tryed testparming
Code:
Load smb config files from smb.conf
Processing section "[share]"
Processing section "[public]"
Loaded services file OK.

Last edited by yus-suf; 06-01-2009 at 05:31 PM.
 
Old 06-01-2009, 05:37 PM   #7
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
That doesn't look right

try
Code:
[share]
writeable = yes
admin users = smbuser
path = /sambashares/share
force user = root
valid users = smbuser
public = yes
available = yes
Try "smbclient -L localhost" on the local machine
 
Old 06-01-2009, 05:40 PM   #8
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Actuall, I doubt "valid users" and "security =share" can work together. Try "security = user"
 
Old 06-01-2009, 05:49 PM   #9
yus-suf
LQ Newbie
 
Registered: Jun 2009
Posts: 7

Original Poster
Rep: Reputation: 0
edit 2:
didn't see you wrote more billymayday
it says lanman auth disabled ?
Code:
smbclient -L localhost
Enter root's password:
Domain=[WRKGRP] OS=[Unix] Server=[Samba 3.2.4-0.22.fc10]
Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
tree connect failed: SUCCESS - 0
i changed the path and security and restarted
maybe i forgot to run a service
/etc/init.d/smb start
is the only one started

edit1:

first when i typed username and pass in it gave permission acces error
now it only gives me network path cannot be found
Code:
 ==in the / directory
[root@fedora sambashares]# ls -l
total 8
drwxrwxrwx 2 smbuser smbuser 4096 2009-06-01 15:35 public
drwxrwxrwx 2 smbuser smbuser 4096 2009-06-01 15:35 share
Code:
[global]
workgroup = wrkgrp
netbios name = smbserver
security = SHARE
load printers = No
default service = global
path = /sambashares
available = yes
encrypt passwords = yes

[share]
writeable = yes
admin users = smbuser
path = /sambashares/share
force user = root
security = SHARE
public = yes
available = yes

[public]
path = /sambashares/public
public = yes
only guest = yes
writable = yes
printable = no
available = yes

Last edited by yus-suf; 06-01-2009 at 06:01 PM.
 
Old 06-01-2009, 06:09 PM   #10
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
You don't have root as a samba user. Try "smbclient -U smbuser -L localhost"
 
Old 06-01-2009, 06:22 PM   #11
yus-suf
LQ Newbie
 
Registered: Jun 2009
Posts: 7

Original Poster
Rep: Reputation: 0
i had to put this in smb.conf [global]
Code:
lanman auth = yes
client lanman auth = yes
to get this
Code:
# smbclient -U smbuser -L localhost
working

result
Code:
[root@localhost samba]# smbclient -U smbuser -L localhost
Enter smbuser's password:
Domain=[WRKGRP] OS=[Unix] Server=[Samba 3.2.4-0.22.fc10]

        Sharename       Type      Comment
        ---------       ----      -------
        share           Disk
        public          Disk
        IPC$            IPC       IPC Service (Samba 3.2.4-0.22.fc10)
Domain=[WRKGRP] OS=[Unix] Server=[Samba 3.2.4-0.22.fc10]

        Server               Comment
        ---------            -------

        Workgroup            Master
        ---------            -------
[root@localhost samba]#
sorry if i am not beeing really helpfull

edit : its telling me
the network path was not found

Last edited by yus-suf; 06-01-2009 at 06:26 PM.
 
Old 06-01-2009, 06:26 PM   #12
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Getting there.

What happens when you try and map the drive from Windows, telling it to "connect as different user name" in the map dialog and add smbuser as the username? Try connecting to the share drive.

ps - I don't think you want that global path directive - comment it out

I'll be offline for a while
 
Old 06-01-2009, 06:32 PM   #13
yus-suf
LQ Newbie
 
Registered: Jun 2009
Posts: 7

Original Poster
Rep: Reputation: 0
it gives me
Code:
the network \\ip\shares path cannot be found
i'm going to put the shares to its original place and see if it works then

edit:
still not working
Code:
[global]
workgroup = wrkgrp
lanman auth = yes
client lanman auth = yes
netbios name = smbserver
security = SHARE
load printers = No
default service = global
path = /home
available = yes
encrypt passwords = yes

[share]
writeable = yes
admin users = smbuser
path = /home/share
force user = root
security = SHARE
public = yes
available = yes

Last edited by yus-suf; 06-01-2009 at 06:48 PM.
 
Old 06-01-2009, 07:06 PM   #14
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Do an experiment for me.

#setenforce 0

then try again. It may just be SELinux causing problems.
 
Old 06-01-2009, 07:31 PM   #15
yus-suf
LQ Newbie
 
Registered: Jun 2009
Posts: 7

Original Poster
Rep: Reputation: 0
WOW thnx man it actually worked thnx a bunch Love you man THANK YOU SO MUCH!1!!!

gonna test it further tommorow tired as hell been working on it 16 houres today
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
School Project Bovine64 Linux - Networking 2 04-17-2006 07:15 PM
help needed with school project pyar Programming 9 02-03-2005 05:48 PM
I need a little help for a school project... Tsuroerusu General 25 12-12-2004 08:34 AM
School project... HLDS Shr00mBoXx Linux - Games 8 06-26-2004 06:31 PM
My school project Growly Linux User Groups (LUG) 1 04-30-2004 05:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration