LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   SATA with Windows, IDE with linux lilo problems (https://www.linuxquestions.org/questions/linux-newbie-8/sata-with-windows-ide-with-linux-lilo-problems-290335/)

jshowe 02-14-2005 09:44 PM

SATA with Windows, IDE with linux lilo problems
 
Hi all,
As the subject suggests I recently installed Fedora on a secondary IDE hard drive. Prior to the install the computer had an image from the SATA drive (that has windows installed) and the SATA was the primary boot device ( I mention this only to say that the SATA was booting as the primary even with a bootable partition on the IDE). After setuping lilo, I can not boot to the SATA with windows. So, I removed the windows partition on the ide(the image that I had - it was divided in half so I could keep a backup of the SATA just in case - but thought it might have been causing the problems). Now, Linux still boots but when I select sda1 from the menu I get just a blinking cursor.
How can I boot to the SATA??

So to some things up currently:
IDE - secondary - contains linux partitions and a fat32 partition with nothing on it
SATA - primary - contains Windows XP (which I can boot to if the IDE is not plugged in)

After seeing some of the posts on the internet I decided to follow some of the instruction from other people and post some information:
fdisk -l reveals;
Code:

Disk /dev/hdb: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start        End      Blocks  Id  System
/dev/hdb1              1        3811    30611826    c  W95 FAT32 (LBA)
/dev/hdb2            3812        3824      104422+  83  Linux
/dev/hdb3            3825        4865    8361832+  8e  Linux LVM

Disk /dev/sda: 37.0 GB, 37019566080 bytes
255 heads, 63 sectors/track, 4500 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1  *          1        4500    36146218+  7  HPFS/NTFS

lilo.conf reveals:
Code:

prompt
timeout=20
default=sda1
boot=/dev/hdb
map=/boot/map
install=/boot/boot-menu.b


image=/boot/vmlinuz-2.6.9-1.667
        label=linux
        initrd=/boot/initrd-2.6.9-1.667.img
        read-only
        root=/dev/VolGroup00/LogVol00
        append="rhgb quiet"

other=/dev/sda1
        label=Windows

Thank you for the assistance.
-Scott


All times are GMT -5. The time now is 04:31 PM.