LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   sata-ide combo hard drive setup (https://www.linuxquestions.org/questions/linux-newbie-8/sata-ide-combo-hard-drive-setup-511246/)

Berticus 12-16-2006 11:01 PM

sata-ide combo hard drive setup
 
So I have three hard drives:
  • SATA with ZenWalk
  • SATA with Windows XP
  • IDE vfat (for sharing)
With my motherboard, IDE hard drives ALWAYS have presidence over SATA hard drives. I've tried different partition tables but lilo won't install properly, and it won't say why. I know I could use one of the SATA for sharing, and just put Linux on the IDE, but I'd really rather not, and I don't wanna work with nt bootloader to dual boot, I'd really prefer either grub or lilo.

I've been thinking about just putting another Linux distro on the IDE hard drive, but I don't know which distro I should put on it. I want it to be really slim since I'd rarely boot into it.

jonwatson 12-17-2006 03:37 AM

Hi Berticus,

Can you elaborate more on how Lilo won't install. Is it the "Lilo did not install on /target/" error or something else? Does the machine boot, but then halt with something like "LI" or "LIL" on the screen?

I run a server with a single IDE and a SATA RAID5 drive on it and it's working well. I have another server that whines about the setup which is why I'm curious about your setup. We might be able to work through this if I had a little more info.

Berticus 12-17-2006 10:20 AM

Well the message comes up at installation time. In ZenWalk, when you setup lilo, you can choose to install it on the MBR, floppy, or a bootdisk (I think). I chose to install it on MBR, and it'll attempt to install it, but then it'll say, "Lilo failed to install" with a whole lot of other stuff. I believe it says that I have to make a bootdisk.

I was hoping someone else had a solution for me. The computer in question is currently at the university, and I'm home for the holidays (1 month break). So if you need me to boot up into the computer, we'll have to wait for a month.

jonwatson 12-17-2006 12:03 PM

OK, well. I guess we'll need more info on what the "other stuff" is before we can make any sense of it.


All times are GMT -5. The time now is 11:47 AM.