-   Linux - Newbie (
-   -   Sane/Xsane can't find HP scanner (

Mark_in_Hollywood 04-10-2006 10:48 PM

Sane/Xsane can't find HP scanner
Xsane in Sane and I'm not sane, but:

mark@lexington:~$ lsusb
Bus 001 Device 005: ID 03f0:0105 Hewlett-Packard ScanJet 4200c

sudo sane-find-scanner

found USB scanner (vendor=0x03f0, product=0x0105) at libusb:001:005

# Your USB scanner was (probably) detected. It may or may not be supported by SANE. Try scanimage -L and read the backend's manpage.

mark@lexington:~$ scanimage -L

No scanners were identified. If you were expecting something different, check that the scanner is plugged in, turned on and detected by the sane-find-scanner tool


Backend: hp4200 (1.0-2, NEW!)

Manual page: sane-hp4200
Manufacturer Model Interface Status Comment
ScanJet 4200C USB basic 8bpp color, 75/150/300/600 dpi only
ScanJet 4200Cxi USB basic 8bpp color, 75/150/300/600 dpi only
ScanJet 4200Cse USB basic 8bpp color, 75/150/300/600 dpi only

So the backend is up-to-date. Errhh, I mean there is a proper backend, how can I tell if I have it?

Shows backends, but I am too newbee to know what to do. When I tried to download the:


FireFox download manager asked if I wanted "open with archive manager". I don't know if that's correct or not.

Anybody have a clue?
Dell Dimension 4100 730 Meg CPU, 256 Meg RAM, 40Gig HDD, PM560LKI 56K v.90 dial-up modem (Lucent Venus). Brother HL-1440 printer.

b0uncer 04-11-2006 03:22 AM

sane-backends-1.0.17.tar.gz is a gzipped tar archive, that is, a bunch of files compressed to a smaller size and in one file. Like a WinZip's .zip archive, but made a bit differently. The contents probably include the backends, or an installer (I don't know, but I'd guess the backends?)

You can open it using the archive manager as firefox suggested, and then extract it - but if you're running as a normal user, you cannot extract it to the location you'd need to - probably. Read the sane's man pages to find out where the backends are located. I still think you already have them..first try to see if you need to edit some configuration file for your scanner (located in /etc/sane.d/ so I'd guess your config file is /etc/sane.d/hp4200.conf or /etc/sane.d/hp.conf -- these are the files I have on my machine, but I think you have the same).

From the console, you can try to look for these:

locate sane | grep conf | grep hp
(you get the file(s) probably matching your scanner)
sudo <your-editor-name-here> <file-name-from-above>

where <your-editor-name-here> is your favorite editor (vim, nano, emacs, gedit, ...) and <file-name-from-above> is the file name you got using locate - say, /etc/sane.d/hp4200.conf

Then just go through the file and see if there's anything you need to alter there. The hp4200.conf is quite a short one, actually you can only change the usb line there..and I cannot really tell you how.

But yeah, try to install the backends. Read sane's man page(s) and find where the backends ought to be in. Then extract the .tar.gz you downloaded, using

sudo tar -xzf sane-backends-1.0.17.tar.gz

in the directory you need to put them in..

Mark_in_Hollywood 04-11-2006 11:05 AM

Success, after much fooling around Xsane/sane are up-and-running.

Thanks all who support Linux

sir_oliver 04-18-2006 08:26 AM

So what did you do to make it work?


Mark_in_Hollywood 04-19-2006 12:21 AM

I am using Ubuntu. It has an update / upgrade manager called Synpatic. After using it for nearly 300meg of updates/upgrades, SANE worked. Sorry, I wish I could have been more help.

All times are GMT -5. The time now is 06:33 AM.