LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-14-2003, 12:30 PM   #31
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15

I think then something is wrong with your inetd.conf
Or you haven't done as suggested and restarted inetd?
Alternatively, you could notify us whether you can access other network-services such as ftp, ssh, telnet, http , so we'll know there is no network problem
 
Old 10-14-2003, 12:38 PM   #32
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
-alm-
I have restarted and killed inetd tons of times. i dont know what could be wrong with my inetd.conf file. i used mandrake 9.1 before and that pretty much set everything up for me. but this is very frustrating.

I am on the internet so i would think that it cant be a network problem
 
Old 10-14-2003, 12:39 PM   #33
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
i can use ftp
 
Old 10-14-2003, 12:59 PM   #34
jdc2048
Member
 
Registered: Jul 2002
Location: Ohio, USA
Distribution: Redhat, Gentoo, Solaris, HP-UX, etc...
Posts: 391

Rep: Reputation: 30
You won't get any output from the command line, that is normal.

What you need to do is, run "ps -ef | grep swat | grep -v grep", and look for the swat program running. The open a browser and navigate to the localhost:901 page and then run the ps command above again and see if it is there.

If not, then there is a problem with inetd running the program or you have a firewall blocking that port. You may want to run iptables or ipchains to see what is set up on your system.

If it is running and you are getting nothing on your browser, then there is probably a problem with the swat program itself.

<edit>
after looking back, I believe the option you would have had to run would have been "--enable-swat", The "--with-swatdir" will default to a previously specified value. But you would have had to do the "--enable-swat" option in order to get this.

Last edited by jdc2048; 10-14-2003 at 01:04 PM.
 
Old 10-14-2003, 02:50 PM   #35
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
there is nothing when i type ps -ef | grep swat | grep -v grep

when i typed in iptables i have no idea what all that means because i am pretty new to all this.

i am pretty sufre that i dont have a firewall up
 
Old 10-14-2003, 03:02 PM   #36
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15
You could try and see if you can use any other inetd service. Did you try to ftp to your own machine (ftp localhost)? In case ftp is not an inetd service, try to telnet to your own machine. If that doesn't work, see if telnet is enabled in inetd.conf; and if it isn't, enabled it, restart inetd, and try to telnet again.
I hope this made sense.
 
Old 10-14-2003, 03:29 PM   #37
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
when i tried telnet to my own machine it read this

telnet> open
(to) localhost
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused
 
Old 10-14-2003, 04:20 PM   #38
jdc2048
Member
 
Registered: Jul 2002
Location: Ohio, USA
Distribution: Redhat, Gentoo, Solaris, HP-UX, etc...
Posts: 391

Rep: Reputation: 30
If you are getting a bunch of output from iptables, then you probably do have a firewall set up. I know redhat gives you an option during install that will ask you if you want a firewall set up, the default is medium security settings, which pretty much only allows outbound connections to occur.

the fact that you are being refused connection also leans this way.

as root run, "iptables -L", and then post results. X out any identifiable IP's (i.e. 192.168.0.1 becomes xxx.xxx.x.x or <my IP>)
 
Old 10-14-2003, 04:24 PM   #39
garr0323
Member
 
Registered: Oct 2003
Distribution: Slackware9.1, Mandrake9.1
Posts: 70

Original Poster
Rep: Reputation: 15
I GOT IT!!!!!!!!

i went into the inetd.conf and relized that the #'s meant that the code was commented out. so i deleted the # next to the swat tcp/901 and restarted inetd and it worked. thanks a lot to everyone who helped me out. im sure i will have more questions along the way. thanks
 
Old 10-14-2003, 04:31 PM   #40
alm
Member
 
Registered: Mar 2003
Location: Sweden
Distribution: RedHat
Posts: 32

Rep: Reputation: 15
no problem! congratulations!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 02:59 PM
x wont start! Username[SWE] Debian 5 08-02-2004 05:17 PM
x wont start jsmarshall85 Debian 14 07-22-2004 05:41 PM
Samba wont start Chijtska Linux - Networking 5 02-10-2002 08:00 PM
when i restart SAMBA,it says:stop samba failed,start SAMBA OK! whepin Linux - Networking 3 12-26-2001 06:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration