-   Linux - Newbie (
-   -   samba wont let windows into my linux shares (

mrgreaper 06-19-2006 07:04 PM

(SOLVED kinda) samba wont let windows into my linux shares
ok im pulling out my hair
i had suse 10.0 installed
i tried ubuntu
hated it
it wiped the partitons before it instaled
i wiped the partitions again to make sure ubuntu was gone
i installed suse 10.0 again thought it would update to 10.1 at update stage but nevermind

i set it up same as i did last time
now i can access my windows shares on linux
but heres my problem;
if i go to \\linux or even through my network places i see a list of shares but if i try to access the ones with the same name as the old ones it says access denied (ok the dialog is more detailed then that but its the standard incorrect password type thing) now if access any of them with new names it brings up the user name password dialogue i type my linux login details (the same as i did before the ubuntu disaster) and well computer says no
i have the samba user authentication set to smbpasswd file with the value of my password
i really dont know what else to do i have googled till my fingers bleed and cant find the solution

3:36 am still cant access the shared folders please any help rould be appreciated

prozac 06-19-2006 09:46 PM

IMO, this may the case of missing owner. check for the owner/group of those shares. If it shows numbers instead of name, change the owner to current user by doing

chown -R username: dir_name

mrgreaper 06-20-2006 06:54 AM

still cant access them
i have no idea how to check the owner of a folder
but i created a new folder and chowned it to me (i assume it would be any way)
put one of the share folders is my folder in home so i assume thats owned by me by default?

i keep going through the samba server settings hoping i`ll find something i`ve missed but im truely at a loss

my smb.conf file (though i edit it with yast) of course i edited the password

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2006-04-05
        workgroup = Davesnet
        printing = cups
        printcap name = cups
        printcap cache time = 750
        cups options = raw
        map to guest = Bad User
        include = /etc/samba/dhcp.conf
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        domain logons = No
        domain master = No
        security = user
        idmap gid = 10000-20000
        idmap uid = 10000-20000
        passdb backend = smbpasswd:*******
        comment = Home Directories
        valid users = %S
        browseable = No
        read only = No
        inherit acls = Yes
        comment = Network Profiles Service
        path = %H
        read only = No
        store dos attributes = Yes
        create mask = 0600
        directory mask = 0700
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/
        comment = All groups
        path = /home/groups
        read only = No
        inherit acls = Yes
        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775

        comment = root of home
        path = /home/mrgreaper/
        read only = No

## Share disabled by YaST
# [netlogon]

        comment = webserver folder
        path = /srv/www/
        read only = No

        comment = test folder
        inherit acls = Yes
        path = /home/mrgreaper/daves/
        read only = No

ok could this file be the problem if so how can i fix it?
smbusers file

# This file allows you to map usernames from the clients to the server.
# Unix_name = SMB_name1 SMB_name2 ...
# See section 'username map' in the manual page of smb.conf for more
# information.

root = administrator
;nobody = guest pcguest smbguest

the smbpasswd file cant be opened if you try double clicking it and has a little re cross on its icon in gnome i assume thats normal

the error i get on a windows pc when i try to access the share

title : Samba 3.0.20b-3.3-suse (linux)
contents of the message box: \\linux\daves is not accessible. You may not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Multiple connections to a server or shared resource by the same user, using more then one user name, are not allowed. dissconnect all previous connections to the server or shared resourceand try again
the last bit of the error message seems to be untrue as before i could connect all three of my machines to the files on (that includes an xbox using media center and samba to play my girlfriends music through the tv ...i dont mind if we never fix that :) ) but they could all connect to it at the same time using my linux user n pass

this is truely driving me nuts please help

Nylex 06-20-2006 07:44 AM

Does it work if you change the security level to share (i.e. "security = share " in your global section)? I think that is what works for me. Check the SAMBA documentation, as it does give explanations of the different security levels IIRC. Remember that you'll need to restart the server after you've made changes to your smb.conf.

mrgreaper 06-20-2006 09:10 AM

hmmm didnt work im afraid ... i definatly feel its a password issue as the shares that were set up and have password saved on the windows pc just say access is denied the others come up with the above error or when set to share in security just ask me for the password again and again and again and again

i opened my smbpasswd file as root and was surprised at the content

# This file is the authentication source for Samba if 'passdb backend' is set
# to 'smbpasswd' and 'encrypt passwords' is 'Yes' in the [global] section of
# /etc/samba/smb.conf
# See section 'passdb backend' and 'encrypt passwords' in the manual page of
# smb.conf for more information.

i`m assuming my pass word should be here ? but it aint :(

i updated to the latest stable samba release 3.0.22-17.1.28 still no go
theres gotta be a solution

mrgreaper 06-20-2006 10:30 AM

ok using that webpage i typed ;

Failed to find entry for user mrgreaper.
Failed to modify password entry for user mrgreaper
linux:/home/mrgreaper # smbpasswd -e mrgreaper
Failed to find entry for user mrgreaper.
Failed to modify password entry for user mrgreaper
linux:/home/mrgreaper # smbpasswd -a mrgreaper
New SMB password:
Retype new SMB password:
Added user mrgreaper.

but its still no go !!!!!!!!!!!!!!! arghhhhhhhhhhhhhhhh

all i have done since i got up is google samba read about how to use it normally in language above my linux cpabilitie

now one thing i came across said you can make samba just allow certain hosts the example i believe was
host =
and there was a deny host line of but cant renember that
so what i`d like to do if possible ;
1 remove the password entirely i`m happy that anyone on my network can access my windows shares so why not my linux ones
2 to make it a bit securer then i`d like to use the the host option and allow a range between - to

shows how secure windows(edit i ment linux) is i guess as i cant even access my own filesacross the network :(

ok i admit defeat and throw my self at your merci i cant find info to help me im gonna try to remove samba completely then reinstall it (the standard windows user approach)
i cant think of anything else! HELP!!!
it would apear deleting samba is not an option :(
ummm i may of typed this before but hell i`ll type it again HEEEEELP! please

i`ve posted for help on samba`s irc thing not sure i have done it right or not irc seems to be a chat programme but i posted the prob and a link to this page but i dont think it even posted right :(

this is gonna be the death of me im sure of it i just dont understand whats wrong

mrgreaper 06-20-2006 12:33 PM

ok my problem is solved ...well work arounded
so it may help others here is a duplicate of the samba irc forum thing


<Thanster> so is this your first samba setup?
<mrgreaper> has details of my problem
<mrgreaper> yes and no
<mrgreaper> i had it all set up
<mrgreaper> went to ubuntu
<mrgreaper> went back to suse 10.0
<mrgreaper> thats when it stoped working
<Thanster> ok you are not operating a domain, just a workgroup...?
<mrgreaper> yep a workgroup "davesnet"
<mrgreaper> i can see the linux shares from any computer juat cant access them
<Thanster> Is it a shared network at all, I can probably tell you what you need to do to make it pretty open but obviously less secure
<mrgreaper> its conected to the internet through a router but the network itself is all in my frontroom /kitchen the windows shares are open to any comp that plugs into my router so i dont mind the same being done on my linux box
<mrgreaper> in fact id like it like that
<Thanster> ok here is a sample share that should work for you as a general read/writeable share
<Thanster> [myshare]
<Thanster> path = "some path"
<Thanster> guestok = yes
<Thanster> force user = linux user with write access to this space
<Thanster> read only = no
<Thanster> obviously you need to change the path and users to things appropriate to your linux box
<prothi> hi all
<mrgreaper> ok i`ll try that now
<mrgreaper> thank you
<Thanster> guestok might be "guest ok" I cant remember
<mrgreaper> that worked!
<Thanster> glad to have helped :-)
<mrgreaper> omg thank you guess i just have to add the guestok= yes and force user = me to the other shares and theyll work too

i added

hosts allow =
hosts deny =
 guestok = yes
 force user = mrgreaper

to my global section of smb.conf
and now all my shares work ith out asking me for password (same as the windows ones)
the ;
hosts allow =
hosts deny =

mean that only ips in the alow range can see and use the samba shares so if someone wanted to use my files they would physicly have to be in my flat (i think i may notice them)
though as i have said before i have no enemys so i doubt anyone would want to try

All times are GMT -5. The time now is 03:37 AM.