LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Samba shares not available to windows machines on the network (https://www.linuxquestions.org/questions/linux-newbie-8/samba-shares-not-available-to-windows-machines-on-the-network-4175536807/)

joe30030 03-15-2015 02:26 PM

Samba shares not available to windows machines on the network
 
Linux 14.04 server set up following instructions on http://www.havetheknowhow.com

I have been trying to connect to the samba shares from two windows machines. The server is visible but when I try to connect it requests a logon and no matter what I enter it fails. I have been using webmin to set this up and the samba version is 4.1.6-ubuntu.
One note, webmin did not show any samba user groups.

all systems show "WORKGROUP" as the workgroup

joe30030 03-15-2015 06:09 PM

Alright. this seems to be fixed. I went through all the steps in webmin and changed all the user passwords, restarted samba and it is working. Sigh.

andybrody 03-20-2015 05:55 PM

Quote:

Originally Posted by joe30030 (Post 5332548)
Linux 14.04 server set up following instructions on http://www.havetheknowhow.com

I have been trying to connect to the samba shares from two windows machines. The server is visible but when I try to connect it requests a logon and no matter what I enter it fails. I have been using webmin to set this up and the samba version is 4.1.6-ubuntu.
One note, webmin did not show any samba user groups.

all systems show "WORKGROUP" as the workgroup

Hi I hope you may be able to help me.
I have been trying to do the exact same thing and getting nowhere with this.
Can you please take me thru how you did this I can see my NAS in the network if I click it i get up the the share i have created as a temp for testing. If I then try to access the share i get asked for a username and password and never get any further.
Any help would be greatly appreciated.
Regards
Andy

joe30030 03-20-2015 08:36 PM

There were actually two things that may have been the resolution.

The first was the password for the user. In the instructions on creating shares on havetheknowhow.com, they tell you to change the password in webmin after setting it up(the new one can be the same as the old, but evidently it just needs to be changed)

the second was ownership of the share. In webmin I could not find the share owner and group listing and in my google searches I found instructions for "chown"
chown -R newowner:newgroup /folder

ONe of those two things solved my particular problem. good luck and let me know which one solved it.

dakoris73 03-22-2015 09:14 AM

Ya, I had similar problems with my server not allowing me to log in to my samba shares either.... I believe the fix for this was changing the ownership to the share using the chown command.

Good luck and have fun with your new server........

thegwer 03-22-2015 02:24 PM

Besides the permissions of the actual linux user account you have to add a Samba user to authenticate the share.

Use

# smbpasswd -a joe
Joe being the existing user on your system

Then edit your smb.conf file and make sure you add a valid user = joe


Hope this helps.
see this link for more detials
http://www.cyberciti.biz/faq/adding-...mba-smb-share/


All times are GMT -5. The time now is 08:22 PM.