-   Linux - Newbie (
-   -   Samba share disappeared. Works on some machines, not on others (

Damarr 12-07-2011 01:12 PM

Samba share disappeared. Works on some machines, not on others
Hopefully someone can help, because I've given up on being able to find the answer myself.

I have a mixed environment (windows 7, windows 2003, windows 2008, RHEL, Mac OSX) and for some strange reason some of my machines can no longer access a samba share on our RHEL server, and can't access the share on the OSX server.

All computers used to be able to see the shares not a month ago.

It started out with one of our 2003 servers. than the other. next was a windows 7 machine. then another. I have not found any 2008 servers that are having issues.

I've changed our smb.conf to match the one on another server that works fine
Didnt help.

Made the requiste changes to security policy (send unencrypted password to third party smb servers 'enabled' and lan manager authentication level 'send LM & NTLM - use v2 blah blah' the did a gpupdate /force to make sure the policy was applied
No change, didn't help

opened up a windows 7 machine that works and one that doesnt work. compared the list of installed programs - they were all the same

uninstalled kb2536276 - no change

compared all installed security updates on the windows 7 machine that doesn't work with all the installed security updates on the one that does - they were all the same

I don't know what else to try.

Anyone that can suggest something I haven't tried or what worked for them would be very much appreciated



Damarr 12-07-2011 01:54 PM

The only clue that I forgot to mention is that on the ones that the samba share doesn't work, a challenge response pops up asking for a username and password. No combination of username or password works. On the machine that can see the share, it doesn't even ask.

coolsg5636 12-07-2011 09:04 PM


Can you please paste the smb.conf file's content ?

Were you using any username/password for samba share ?

Have you applied any patch/update to the RHEL machine ?

Any changes in the networking part ?

All times are GMT -5. The time now is 11:34 PM.