LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-27-2006, 02:10 PM   #1
dareino
Member
 
Registered: Mar 2004
Location: S.F.,Ca
Distribution: FC4
Posts: 82

Rep: Reputation: 15
Samba question


While logged into XP, I was able to connect to a storage vfat hhd on my Linux box and was able delete files w/o a problem. I upgraded from FC4 to FC5 and now I lost this permission. Actually I installed FC5 after a format. Anyways while logged in Linux, I can connect and delete XP files w/o a prob. I have changed the smb files many times but I cannot for the life of me fix this prob. The two hdd partitions in question are Win and XP. Also this smb file is what I used w/FC4 and it worked just fine...
Please help!
thxs
dr



# Samba config file created using SWAT
# from 0.0.0.0 (0.0.0.0)
# Date: 2006/03/19 12:29:19

# Global parameters
[global]
workgroup = JARCO
server string = Samba Server
interfaces = 192.168.1.1/255.255.255.0
security = SHARE
encrypt passwords = No
log file = /var/log/samba/%m.log
max log size = 50
time server = Yes
socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192
os level = 65
dns proxy = No
wins support = Yes
ldap ssl = no
default service = global
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
path = /home/darco
read only = No
create mask = 0777
directory mask = 0777
guest ok = Yes
cups options = raw

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[win]
path = /mnt/win
force user = darco
create mask = 0555
directory mask = 0555
hosts allow = 192.168.1.0/24

[tmp]
path = /tmp

[xp]
path = /mnt/xp
force user = darco
create mask = 0555
directory mask = 0555
hosts allow = 192.168.1.0/24

[darco]
force user = darco
create mask = 0555
security mask = 0555
directory mask = 0555
directory security mask = 0555
guest only = Yes
hosts allow = 192.168.1.0/24

[downloads]

path = /home/darco/downloads
hosts allow = 192.168.0./24
 
Old 03-27-2006, 03:03 PM   #2
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,402
Blog Entries: 1

Rep: Reputation: 65
Try to disable SELinux. "system-config-securitylevel" and in SELinux tab set it to disabled.
 
Old 03-27-2006, 03:46 PM   #3
dareino
Member
 
Registered: Mar 2004
Location: S.F.,Ca
Distribution: FC4
Posts: 82

Original Poster
Rep: Reputation: 15
SElinux was already disabled.....thxs tho
 
Old 03-27-2006, 04:31 PM   #4
dareino
Member
 
Registered: Mar 2004
Location: S.F.,Ca
Distribution: FC4
Posts: 82

Original Poster
Rep: Reputation: 15
ok, it works...I followed the advice from another post and set my hdd settings via fstab w/umask=000. I had 002.
dr
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about Samba eagle683 Linux - Newbie 3 06-15-2005 04:02 AM
samba question bjs Linux - Newbie 10 11-02-2004 08:03 PM
samba question grizwold Linux - Software 4 09-07-2004 04:22 PM
samba smb.config question (quick question) TheDOGG Linux - Networking 1 03-02-2004 08:19 AM
RE: Samba question pls help {Newbie question} Radiouk Linux - Networking 4 06-03-2002 07:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration