LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Samba Public Folder (https://www.linuxquestions.org/questions/linux-newbie-8/samba-public-folder-32386/)

DerrickCheang 10-09-2002 09:38 PM

Samba Public Folder
 
Hi,

My problem is that after getting the samba server running.
I cannot seem to use the public folder. When I try to create new folders, it fails
The individual user's folders are working fine

here's my smb.conf file, is there something missing?

[global]
smb passwd file = /etc/samba/smbpasswd
domain master = yes
printing = lprng
dns proxy = no
encrypt passwords = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
wins support = true
printcap name = /etc/printcap
max log size = 0
security = user
domain logons = yes
server string = Samba IBM Server
workgroup = Company
local master = yes
log file = /var/log/samba/%m.log
load printers = yes
os level = 33

[homes]
comment = Home Directories
browseable = no
writable = yes
valid users = %S
create mode = 0664
directory mode = 0775

[netlogon]
path = /usr/local/samba/lib/netlogon
writable = no
browseable = no
guest ok = yes
comment = Network Logon Service
share modes = no
available = no

[Profiles]
path = /usr/local/samba/profiles
browseable = no
guest ok = yes



[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
# Set public = yes to allow user 'guest account' to print
guest ok = no
writable = no
printable = yes


[public]
path = /home/public
writable = yes
create mode = 777
directory mode = 777
available = yes
comment =
valid users = derrick,cynthia
write list = derrick,cynthia

pclark 10-23-2002 05:20 PM

Here's mine. Works for me with 6 Windows machines using it.

Global parameters

[global]

workgroup = MYGROUP

server string = Samba Server

map to guest = Bad Password

root directory = /

password level = 8

username level = 8

log file = /var/log/samba/%m.log

max log size = 0

time server = Yes

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

domain logons = Yes

wins proxy = Yes

wins support = Yes

hosts allow = 192.168.0. 127.

hosts deny = none

printing = lprng

encrypt passwords = yes



[homes]

comment = Home Directories

valid users = %S

read only = No

create mask = 0664

directory mask = 0775

browseable = No

guest ok = yes



[printers]

comment = All Printers

path = /var/spool/samba

printable = Yes

browseable = No



[public]

comment = Public Stuff

path = /home/samba/common

read only = No

guest ok = Yes



[tmp]

comment = temporary files

path = /tmp

guest ok = yes



[cdrom]

comment = cdrom

path = /mnt/cdrom

browseable = yes

writable = no

guest ok = yes



[floppy]

comment = floppy

path = /mnt/floppy

browseable = yes

writable = yes

guest ok = yes

pclark 10-23-2002 06:16 PM

Sorry, correction. That was an old copy and won't do what you need. This one works. Key is read only = no.

# Samba config file created using SWAT
# from UNKNOWN (127.0.0.1)
# Date: 2002/10/23 18:44:05
# Global parameters
[global]
workgroup = MYGROUP
server string = Samba Server
encrypt passwords = Yes
map to guest = Bad Password
root directory = /
password level = 8
username level = 10
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
domain logons = Yes
wins proxy = Yes
wins support = Yes
hosts allow = 192.168.0. 127.
hosts deny = none
printing = lprng
preserve case = No
short preserve case = No
[homes]
comment = Home Directories
valid users = %S
read only = No
create mask = 0664
directory mask = 0775
browseable = No
[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No
[tmp]
comment = Temporary Files
path = /tmp
[public]
comment = Public Stuff
path = /home/samba
username = DAD, MOKRAY, PHILIP, DANIELA, NATHANIEL
read only = No
guest ok = Yes
[cdrom]
comment = LNXSERVICE cdrom
path = /mnt/cdrom
[floppy]
comment = Lnxservice floppy
path = /mnt/floppy
read only = No

kusumoto 10-29-2002 06:04 AM

If you depend on user , edit there .
(Sorry I can't write English so much !)

[public]
path = /home/public
writable = yes
create mode = 777
directory mode = 777
available = yes
comment =
valid users = derrick,cynthia
write list = derrick,cynthia
""""force user = root""""""

I think you can create a new folder!!


All times are GMT -5. The time now is 09:22 PM.