LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Newbie (http://www.linuxquestions.org/questions/forumdisplay.php?f=8)
-   -   samba problem: tree connect failed: NT_STATUS_BAD_NETWORK_NAME (http://www.linuxquestions.org/questions/showthread.php?t=804268)

DarkSlayer 04-26-2010 09:30 AM

samba problem: tree connect failed: NT_STATUS_BAD_NETWORK_NAME
 
Hi everyone.
Yes i've already checked all topics regarding this problem, but nothing worked for me !!!
SO:
Code:

smbclient //localhost/home/recor -U recor
Password:
Domain=[xxxxxx] OS=[Unix] Server=[Samba 3.0.33-3.15.el5_4.1]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME

also tried it's ip instead localhost
Can't connect from Windows machine as well

Software:
samba-3.0.33-3.15.el5_4.1
samba-client-3.0.33-3.15.el5_4.1
samba-common-3.0.33-3.15.el5_4.1
samba-swat-3.0.33-3.15.el5_4.1

Firewall Disabled!
Selinux Disabled!

Auth type: user
System user recor:x:2002:2002::/home/recor:/bin/bash
smbpasswd -a recor
Share permissions are /home/recor = 777
I don't think that workgroup MYGROUP left by default should interfere samba working and connecting to localhost.
But windows network is under Win2k3 DC.
testparm:
Code:

Load smb config files from /etc/samba/smb.conf
Processing section "[recordings]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions
[global]
        workgroup = MYGROUP
        server string = Samba Server Version %v
        passdb backend = tdbsam
        log file = /var/log/samba/%m.log
        max log size = 5120
        cups options = raw

[recordings]
        comment = Recordings
        path = /home/recor
        valid users = recor
        read only = No

smb.conf all other staff in conf file is commented, if requested will place whole conf file.
Code:

#======================= Global Settings

[global]

# ----------------------- Network Related Options -------------------------

        workgroup = MYGROUP
        server string = Samba Server Version %v

;      netbios name = MYSERVER

;      interfaces = lo eth0 192.168.12.2/24 192.168.13.2/24
;      hosts allow = 127. 192.168.12. 192.168.13.

# --------------------------- Logging Options

        # logs split per machine
        log file = /var/log/samba/%m.log
        # max 50KB per log file, then rotate
        max log size = 5120

# ----------------------- Standalone Server Options

        security = user
        passdb backend = tdbsam
        encrypt passwords = yes


[recordings]
        comment = Recordings
        path = /home/recor
        browseable = yes
        public = no
        writable = yes
        valid users = recor


irishbitte 04-26-2010 05:59 PM

If your windows workstations are joined to a Win2K3 domain, the file server, that is, your samba server, must be joined to that domain also, as a domain file server. Samba is capable of doing this. You won't be able to connect to the samba server from a domain joined pc, unless the server is also a part of the domain.

DarkSlayer 04-27-2010 01:19 AM

Ok it could be problem with win stations
but what about connecting to localhost ???
why during connection to localhost i'm getting same error tree connect failed: NT_STATUS_BAD_NETWORK_NAME ?

Quote:

Originally Posted by irishbitte (Post 3948623)
If your windows workstations are joined to a Win2K3 domain, the file server, that is, your samba server, must be joined to that domain also, as a domain file server. Samba is capable of doing this. You won't be able to connect to the samba server from a domain joined pc, unless the server is also a part of the domain.


DarkSlayer 04-27-2010 02:25 AM

i mentioned that it works :

i can access samba server from: My network Places => Microsoft Windows Network => Mygroup(samba) => server => share

but i can't access to it directly from explorer like \\192.168.3.250\home\share
and still can't login to samba localhost from same server
tried all path combinations and slashes

Randeep 04-27-2010 02:48 AM

have a look

Samba configuration:
http://helpinlinux.blogspot.com/2010...ure-samba.html

Samba-SWAT
http://helpinlinux.blogspot.com/2010...amba-swat.html

DarkSlayer 04-27-2010 06:46 AM

thanks
but what does this mean ?
i read hundreds of such tuts

Quote:

Originally Posted by Randeep (Post 3948977)


irishbitte 04-27-2010 07:03 PM

is your samba server joined to the windows domain? If it is, then the 'workgroup' parameter needs to be the same as the domain name. Also, is localhost blocked for some reason? There is a simple solution. I recommend getting a test machine, setting up a samba server on it from scratch, say, standard ubuntu samba. Then get it working on the domain to your requirements, and compare the two conf files. That's what I'd do. If there is no difference, you need to look wider, at DNS resolution and such. Windows networks are a pain in the ass, my bet is the samba server is working to spec, and there is some silly setting on the domain controller messing you about.

DarkSlayer 04-28-2010 03:24 AM

Quote:

Originally Posted by irishbitte (Post 3949914)
is your samba server joined to the windows domain? If it is, then the 'workgroup' parameter needs to be the same as the domain name. Also, is localhost blocked for some reason? There is a simple solution. I recommend getting a test machine, setting up a samba server on it from scratch, say, standard ubuntu samba. Then get it working on the domain to your requirements, and compare the two conf files. That's what I'd do. If there is no difference, you need to look wider, at DNS resolution and such. Windows networks are a pain in the ass, my bet is the samba server is working to spec, and there is some silly setting on the domain controller messing you about.

it's not joined to Win Domain
you can almost always get resources from share if you have proper auth info. in this case Username and Password, no restriction like "man you should be part of Domain or get out of here"
i don't know why localhost is blocked and not working
system is CentOS 5.3 based Elastix 1.6 VoIP system
Samba with all it's tools and dependencies was installed by me from scratch via yum. coz it's not included in elastix.

i can access share spending lil much time from My Network Places, against secs using \\192.168.3.250\share in explorer

catkin 04-28-2010 03:39 AM

A good first testing step is to use smbclient with the -L option at the command line on the samba server. BTW, when posting an smb.conf file, the most convenient way is to post the output of testparm -s.


All times are GMT -5. The time now is 07:49 PM.