-   Linux - Newbie (
-   -   Samba Package cant be selected (

zappos 03-07-2005 11:00 AM

Samba Package cant be selected
Mandrake 10.1 Official.

I am trying to add samba server to my system but when I select the check box in the rmp install GUI a dialog appears telling me I cant select it. There are two versions shown and neither will select. I assume the software is on the install disks.
All the install disks are enabled in the media manager as well as contrib, plf-free, updates and main.
I have also updated all the media so am a bit puzzled.

Have I missed something obvious?

Thanks in advance!

Peacedog 03-07-2005 05:40 PM

Are you sure that it's not installed already? Try a locate samba or a whereis samba.
good luck.

zappos 03-07-2005 05:51 PM


It seems to be installed

[root@Linux1 etc]# whereis samba
samba: /etc/samba /usr/lib/samba /usr/share/samba

So not sure why it is showing up in the install options and indeed is not in the remove list either. Neither does it show up in the services list.

How do I add this to the services or should I somehow remove it first then reinstall?

Sorry for the questions but a newbie if you havent guessed!

Peacedog 03-07-2005 06:19 PM

You'll want to configure it then start the service. You may want to look into swat for configuration until you're more familiar with samba.

good luck.

Vijayasarathy 03-17-2005 04:34 AM

Hi Zappos,.

It is first better to know for sure if samba has been installed. You can do this by the "rpm" command.

Use the following line:

rpm -qa| grep samba

if you see some samba package shown , then it means that the package has been installed.

If it doesnt show any samba packages, then you can always download the samba package from the Internet at

After you make sure that samba in installed, you can use the "chkconfig" command to manage services, and therefore, samba too..

use the man page of chkconfig to know cna also use the GUI to get to service management. It shall be availalbe in "System settings ->servers->services"

All the best.


All times are GMT -5. The time now is 10:57 PM.