LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-27-2003, 02:42 PM   #1
jetfanroy
LQ Newbie
 
Registered: Jun 2003
Posts: 4

Rep: Reputation: 0
Samba Issues


I am having a bit of problems getting the Smaba service to run on my Red Hat 9 install.

Forgive me if this topic has already been addressed....

The smb.log is as follows:

[2003/06/27 15:29:43, 0] lib/util_sock.cpen_socket_in(804)
bind failed on port 139 socket_addr = 0.0.0.0.
Error = Address already in use

and the smbstatus command yields:

Samba version 2.2.7a-security-rollup-fix
Service uid gid pid machine
----------------------------------------------

Failed to open byte range locking database
ERROR: Failed to initialise locking database
Can't initialise locking module - exiting

Any help would be gratly appreciated!!
 
Old 06-28-2003, 12:30 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
It sounds like somehtinng is already listenting to that port - (posibly samba is already running)

netstat -l --numeric-ports

and look for somehting listening on port 139
 
Old 06-28-2003, 12:33 PM   #3
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
sorry - just noticed I missed the "p":
netstat -lp --numeric-ports
 
Old 06-28-2003, 12:59 PM   #4
cropcircle
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Red Hat Linux 9, FreeBSD 4.8, Knoppix 3.2
Posts: 182

Rep: Reputation: 30
Maybe another program is running on port 139? Do the following :

"su -"
"service smb stop"

What do you see if you enter the following commands :

"netstat -nlt"
"lsof -i"
 
Old 06-30-2003, 10:19 AM   #5
jetfanroy
LQ Newbie
 
Registered: Jun 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for all of the help -

Actually - there was another Samba server running - I have Vmware loaded and it was using that port - I actually modified the smb.conf file and added a socket address statement with the IP address of the actual interface under the interfaces section of the file.

This allowed the service to start correctly -
Then I had to disable my firewall to connect.

Thanks again for the help!!
 
Old 06-30-2003, 11:40 PM   #6
XSIWILL
LQ Newbie
 
Registered: Nov 2002
Distribution: Suse 10
Posts: 11

Rep: Reputation: 0
I'm having a simlar issue as well, when I run netstat -nlt I can see that it's listening for port 139 but when I try to connect to
127.0.0.1:901 I get a messages that reads Connection refused when trying to connect to that address.

I also notice that I don't have a swat file on /etc/xinetd.d
I am using RH 9.0 samba ver 2.2.7a-8.90

Thanks!
 
Old 07-01-2003, 12:34 PM   #7
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
With Redhat 9 you will need to install the samba-swat package:
ftp://fr.rpmfind.net/linux/redhat/9/...7.9.0.i386.rpm
 
Old 07-01-2003, 04:31 PM   #8
XSIWILL
LQ Newbie
 
Registered: Nov 2002
Distribution: Suse 10
Posts: 11

Rep: Reputation: 0
Thanks David! I also found that RH 9 includes it's own interface as well using redhat-config-samba
 
Old 07-01-2003, 04:34 PM   #9
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Once you get used to it, editing the config file by hand is easy too. I can add a new share in the time it takes my browser to open and get to the right page
 
Old 07-01-2003, 04:41 PM   #10
XSIWILL
LQ Newbie
 
Registered: Nov 2002
Distribution: Suse 10
Posts: 11

Rep: Reputation: 0
Indeed, Thanks again for your assistance!
 
Old 07-29-2003, 08:25 AM   #11
Turbo
LQ Newbie
 
Registered: Jul 2003
Posts: 2

Rep: Reputation: 0
I had the same problem but I downloaded the locking files and it is working now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba issues trebek Linux - Networking 3 04-28-2005 03:10 PM
samba issues cham0169 Linux - Software 1 04-11-2005 08:37 AM
samba issues feldux Linux - Networking 1 08-12-2004 11:06 AM
Samba Issues TheTrexx Linux - Networking 4 12-16-2002 12:30 PM
Samba issues chris Linux - General 4 11-22-2001 04:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration