LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Samba and Shorewall. will the fun ever end? (https://www.linuxquestions.org/questions/linux-newbie-8/samba-and-shorewall-will-the-fun-ever-end-81077/)

Newman_SCO 08-11-2003 05:13 PM

Samba and Shorewall. will the fun ever end?
 
-Mandrake install
-install modem
-configure for internet sharing
-installs shorewall firewall - didn't ask for that.
-Opened ports for ssh and samba. locally and net for shorewall.
-Configure samba (simple workgroup)
-connection refused when accessing share on linux server (windows client)
-ping server, no responce
-opened ping abilities on shorewall.

JOY! thanks for reading so far

-Disabled shorewall.. internet sharing stops.
-Samba still doesn't work with shorewall down.

At this point I feel relaxed. yeah. (keep it cool neil)

-Disabled shorewall
-Installed firestarter. My internet sharing doesn't work. or samba.

I could smile for days on end.


Could anyone give any suggestions in helping me solve my problem. I would much appreciate it.

I have tried to be as detailed as possible.

I hope you have a good day!.

Neil

note: did restart certain services when values changed.

and my linux server harddrive fried today. Bad day! lol

gsibble 08-11-2003 06:06 PM

That sucks :(

Ummm.......if Samba or internet sharing doesn't work without shorewall there must be another firewall in place. Can you at least ping the server now?

In any case, Mandrake is probably the last distro I would use for a server. It's really geared towards desktop use in my opinion. I mean the standard install doesn't even have sshd on it!!

Good luck though dude....you asked the question in the right place at least!!

Newman_SCO 08-12-2003 07:24 AM

No response when I ping still.

No second firewall also.

Thinking about another Distro.

Do you think mandrake security setting being on "Higher" security is stopping these actions. Even when ports are being opened manually.

I have ran out of ideas. Might give redhat a download. :scratch:

Newman_SCO 08-12-2003 12:01 PM

Solved.. I'm so happy.

Just thought I would explain if anyone else ever has this problem.

-Made my samba config very basic:

[global]
workgroup = TITAN
netbios name = SambaServer
security = share
guest ok = yes
guest account = admin

[test]
path = /home/admin
read only = no

-Mandrake recommended "Higher" Security when acting as a server.

-This blocked alot of my features I wanted.

-Access the security level properties by going to the mandrake control centre.

-change to standard, or tweak the settings manually.

Silly thing, if I think about it now.
But tweaking shorewall rules files manually you would think it would overide the high security.

Still no ping. But I know how to solve that now under tweaking echo in security settings.

My Samba and shh/Putty works brilliantly now.

Off to crack open a beer. Harah!


All times are GMT -5. The time now is 11:16 PM.