LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   running windows based programs in linux (https://www.linuxquestions.org/questions/linux-newbie-8/running-windows-based-programs-in-linux-182035/)

gambit 05-16-2004 10:17 AM

running windows based programs in linux
 
I have a dual booting pc with win98 / win2k and redhat linux 7.1

I am trying to get linux to install a chess program ...I know how to
access the fat32 partition and can "see" the setup file.exe
however linux seems not to be able to set it up ??

I heard a rumor that linux can run a windows emulator of sorts to run
fat32 programs ......

can this be done and how ?

heema 05-16-2004 10:40 AM

yeah it can be done with a program called wine
but it cant install any windows program , so u could try it out

http://www.winehq.org

gambit 05-17-2004 04:54 PM

I have now downloaded wine20040505.tar and unzipped it in windows....
now when I go into linux ...I tried installing it in kde.....
the readme said to try --> wine20040505-->>tools-->wineinstall
so I did but nothing happened...I then tried clicking on wineinstall

and then go into the top taskbar--> actions I think--> open in terminal
here it brings up the path root@localhost/tools>wineinstall
I tried this but it showed "command not found"

so then I tried the other option -->execute shell command
as the root user it showed the mesg "installing wine0.7 from root
"is unstable , u need to install it as user" or something to that effect

so I created and logged in using a user account

however on trying "execute shell command" it now showed this mesg
"the source directory is not writable, etc....." and something like
"this was unzipped with a root account"
"u need to unzip this as user" or something to that effect

I can provide exact details if it will help .....
can any1 explain why this is happening or why it seems so hard to run an
executable command ?
any solutions or hints ?


aside from that I noticed that as a simple user I could not create new folders
or copy / delete any stuff?

xanas3712 05-17-2004 09:49 PM

If it was unzipped in root mode you just need to do this

Type su in terminal (it'll ask for your root password)
Type chmod 777 directoryofwine.


All times are GMT -5. The time now is 06:08 PM.