LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-20-2007, 01:46 PM   #1
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Rep: Reputation: 30
running two operative systems


Hi again, here once more to pick the brains that roam the corridors of the linux forum. I have a dell dimension 5000 that I had intended to go over to linux, thus abandoning windows for good, but because of the problem with skype not having a video link - I thought a compromise was in order.

This is the state of play at the moment. I didn't want to have windows on the same sata drive as linux, so I went out and bought a new sata drive today. Well the computer accepts both hard drives OK - windows being on the first and debian etch on the other. The problem is at the moment I have to go into setup and turn one of the drives off so that the other one boots - otherwise windows starts every time.

Is there a way of choosing which system windows or debian without going into setup every time?
I read some where about including a boot partition on windows for linux?
Has anyone any ideas?

bookie
 
Old 06-20-2007, 02:38 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Sure, you can do a couple of things:
1) Leave the Debian drive as the primary drive and then use the linux bootloader to trick windows into thinking it's on the first drive.
2) Install the Debian bootloader to the Windows drive and make windows the primary drive.
3) Use the NTLDR on windows to chainload linux on the second drive.
4) Install a 3rd party bootloader (SBM, XOSL, etc) on whatever primary drive to chainload the others.

If you want to do #1, just add an entry in /boot/grub/menu.lst on Debian for Windows
Code:
title Windows
root (hd1,0)
map (hd1) (hd0)
map (hd0) (hd1)
chainloader +1
makeactive
boot
If you want to do #2, you need to boot with a linux live CD (or grub boot floppy), type grub from a root shell, and then
Code:
root (hd1,0)
setup (hd0)
Assuming Debian is on the secondary drive first partition. If you want to do #3, try this link or this link. If you want to do #4, try google...
 
Old 06-20-2007, 02:50 PM   #3
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,147

Rep: Reputation: Disabled
Thumbs up

@pljvaldez

Very operative post about booting operative systems, one cannot do it any better!
 
Old 06-20-2007, 02:51 PM   #4
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Hi to pljvaldez, thanks for the info. I will get back to you in due course.

Thanks again.

bookie

PS Thanks Emerson. I must agree on your comments. Pljvaldez gets ten out of ten.

Last edited by bookie; 06-20-2007 at 02:52 PM.
 
Old 06-20-2007, 03:09 PM   #5
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Hi to pljvaldez, if I go with option 1, do I add the entry before the debian one, or at the end of the list?
Sorry, keep pressing the wrong keys at the moment. Do I amend to info that is already there? The windows operative I am using is XP and the grub list has the following:


# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#




bookie

Last edited by bookie; 06-20-2007 at 03:18 PM.
 
Old 06-20-2007, 03:20 PM   #6
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Hi again, not to be a pain in the but for you, but if the distro was fedora 7 how would I go about that one as well?

I do apologize for so many posts.

bookie
 
Old 06-20-2007, 04:12 PM   #7
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Can you post your entire menu.lst file? Also the output of fdisk -l (probably performed as root). It'll go a bit quicker if we can see your filesystem.

Fedora also uses grub, but I think it might use a different filename like /boot/grub.conf or something like that. I haven't used a RedHat distro since RH 9.0, so I don't know for sure. But it's basically the same. Add an entry to the appropriate file.
 
Old 06-21-2007, 03:56 AM   #8
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Hi pljvaldez

Sorry I couldn't get back to you sooner - my girlfriend wanted to go to bed - and my dimension 5000 is in the master bedroom.

Well,I have made a few changes to the system this morning. I had already installed debian on one hard drive before I bought the second and installed windows. I have now re-installed debian and while working through the installation I was asked if I would like to install a boot partition on windows. I of course said yes - and the result is - problem solved.

I now have debian on two computers for the mo, so I looked at the /boot/grub/menu.list on my office computer. The last entry on that list was:
Quote:
### END DEBIAN AUTOMAGIC KERNELS LIST
On my dimension 5000:
Quote:
### END DEBIAN AUTOMAGIC KERNELS LIST
# This is a divider, added to separate the menu items below from the Debian
#ones
title other operating systems:
root
# This entry automatically added by the Debian installer for a non-linux os
# on /dev/sdb1
title Microsoft Windows XP Home Edition
root (hd1,0)
saveddefault
makeactive
map (hd0) (hd1)
map (hd1) (hda)
chainloader +1
This now gives me the choice when I start the computer to choose Debian or Windows.

So as you said, if you have debian as sda0 and windows as sdb1 then you should have a dual boot system without changing the setup every time!!

I hope this added info can be of use to others messing around with dualboot systems on separate hard drives. In this case I reprogrammed Debian to see how the /boot/grub/menu.list was written. I would imagine the new entry would have the same result without the need for reprogramming?

Another little problem, is that I programmed the Debian hard drive as follows:

primary partition /boot 100mb
Primary partition / 3GB
Logical partition Swap 4GB (the reason for such a large swap is that I have 1GB ram just at the mo - and will increase to GB in the near future.)
logical partition /usr 8GB
logical partition /usr/local 2GB
logical partition /var 4GB
logical partition /home (what was left of my 250GB hard drive)

The strange thing is that when I click on my swap partition it is completely used up?
I would appreciate a little advice on this and partitioning in general.

bookie

Last edited by bookie; 06-21-2007 at 03:59 AM.
 
Old 06-21-2007, 07:28 AM   #9
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
The swap partition is completely reserved when you create it. This does not mean it's full of stuff.
Run 'top' at the cmd line to see actual use.
 
Old 06-21-2007, 10:12 AM   #10
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Thanks a lot chrism01. That puts my mind at rest.

bookie
 
Old 06-21-2007, 11:22 AM   #11
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Hi pljvaldez

I thought that I would continue with the same thread regarding working with windows and linux.

I included a vfat partition on windows for ease of file transfer between the two os's I have mounted that partition in Debian and edited my fstab to include the partition automatically when loading os's . That side of things works well.

The problem at the mo is that when I go from administration to open the disks manager I get a lot of errors up on the screen. The errors are from the windows hard drive:
couldn't find /tmp/disks-conf-sdb1,sdb5,sdb6,sdb7

My windows vfat partition is sdb5 which is under /mnt/windows.

It is irritating getting these messages every time I open the disks manager. Is there some info I need to amend, so that this doesn't happen all the time?

bookie

PS If anyone feels that I should start a new thread with this topic, then please, don't hesitate to say.

Thanks
 
Old 06-21-2007, 12:15 PM   #12
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
Did you try F9 or something around there at startup?
A halfway decent BIOS should let you choose what drive to boot.
 
Old 06-21-2007, 01:08 PM   #13
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Hi Crashmeister, I think there has been a blip in the communication thingy. I haven't a problem booting the drive I choose? When working in Debian with the disk manager all of the partitions are visible even though linux can't mount them because of them being windows ntfs.
The partition that can be mounted is sdb5 being vfat and that isn't the problem either. Its the fact when I start the disk manager the errors (explained above) come up on the screen.
If there wasn't a problem in mounting the windows ntfs partitions, then I would have to just link the access paths to the individual partitions. But as you know that isn't possible. I just want to
amend some file to stop the annoying popups.

bookie
 
Old 06-21-2007, 03:42 PM   #14
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
I got xp on drive hdb and debian on hda and use the BIOS to choose what to load - of course xp is default ;-)
With my BIOS F9 gives you a window where you can choose where to boot from (it's not in the settings - I wouldn't go for that;too annoying).

You just need to be careful when you install windows.If it is being installed on hda everything is fine - just tell Linux to install the bootloader to the mbr of hdb and boot from hdb for Linux.

If you install windows on hdb and already got the Linux bootloader on the hda mbr you need to either disable hda in the BIOS or if your BIOS doesn't do that physically disconnect the drive.Otherwise your Linux mbr on drive hda will be gone.

Got no idea about the /tmp/disk-conf things - never seen that.
You better open a new thread about that.

BTW - there should be a way to read/write ntfs in Debian.Can't vouch for it but there are drivers for it.

Last edited by crashmeister; 06-21-2007 at 03:47 PM.
 
Old 06-21-2007, 05:36 PM   #15
bookie
Member
 
Registered: Nov 2006
Location: Sweden
Distribution: Testing just about everything.....Debian still a favourite and now Dreamlinux!!
Posts: 320

Original Poster
Rep: Reputation: 30
Thanks for the help crashmeister.
Like you said - I will open a new thread to continue the discussion.

Much appreciated.
bookie
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help me please!!-running c program using rpc in another systems ratheesh Linux - Networking 8 02-10-2009 05:33 AM
LXer: Metasploit 3.0 doesn't pwn systems, black hats pwn systems LXer Syndicated Linux News 0 05-04-2007 10:01 PM
LXer: Australian Post-Production Facility, Frame, Set & Match, Adopts Autodesk's Discreet Flame Visual Effects Systems Running Linux LXer Syndicated Linux News 0 06-30-2006 10:54 PM
ntfs driver fully-operative? evilop Linux - Software 3 09-20-2004 08:55 PM
Need help getting linux box operative sparrot Linux - Newbie 5 11-27-2002 04:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration