LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Running out of disk space (https://www.linuxquestions.org/questions/linux-newbie-8/running-out-of-disk-space-70904/)

ann_tulip18 07-09-2003 05:05 AM

No KDE program installed, only GNOME. It is now deleted.

I have one more question in my mind, EXACTLY Where does the mail server save logs?

Is there any command to delete some log files, automatically?

THAnKS

MasterC 07-09-2003 05:31 AM

There are things like Log Rotators that assist in log removal/archiving. You could use those, then periodically run a cron to clean out the old logs if you didn't wanna keep them around.

And mail servers save logs in various locations, my Postfix system on Gentoo saves them:
/var/log/maillog
And in:
/var/log/everything
But I'm running metalog, so you might wanna check with your system logger to see where it stores it's logs. Most likely it's going to be a subdirectory of /var/log though

Cool

ann_tulip18 07-09-2003 08:44 PM

Meaning... I'll just invoke the logrotate command to the console and then it will display all the log files?
Yesterday I have deleted all the files on /var/log. Today the same files appear again.

Ps. Our mail serer is not sending mail, but it can receive mail (though its delayed).

THANKS?

MasterC 07-09-2003 09:05 PM

Log files are created if they do not exist. It's normal. You can setup a cron job to remove these files on a weekly/daily/hourly basis if you'd like.

As for the sending/receiving bit..
Were you able to send before you tapped out the partition? Did you manually remove any files when trying to free up space? What files were removed when you removed X? If you've still got your mail server files on your box, nothing should have changed? You might need to restart the server though, follow the documentation for it to restart it.

:)

Cool

ann_tulip18 07-09-2003 09:21 PM

I haven't tried to partition the HD.. Yes.. we have removed a file manually (/var ... but we have copy it back, thinking it has no effect on the HD space). I think its the main reason why our server cant send mails.. I restarted postfix here is the error message

[COLOR=darkblue]
postfix/postfix-script: warning : not owned by postfix: /var/spool/postfix/incoming/E/4
postfix/postfix-script: warning : not owned by postfix: /var/spool/postfix/public
postfix/postfix-script: warning : not owned by postfix: /var/spool/postfix/saved
postfix/postfix-script: warning : not owned by group postdrop: /var/spool/postfix/public
postsuper: fatal: scan_dir_push: open directory defer: Permission Denied
postfix/postfix-script: fatal: Postfix integrity check failed!




What should we do then??

THANKS

MasterC 07-09-2003 09:24 PM

Hmm... Let's try to setup the ownership then:
chown -R postfix.postdrop /var/spool/postfix (this needs to be run by root)
Now try restarting postfix again.

Cool

**I've looked up my own permissions, try this instead:
chown root.root /var/spool/postfix
chown postfix.root /var/spool/postfix/*
chown postfix.maildrop /var/spool/postfix/maildrop /var/spool/postfix/public

While I look up permissions, try those instead.

Cool

ann_tulip18 07-09-2003 09:35 PM

I tried it... and then restart the postfix (postfix start) theres a message again:

postfix/postfix-script: warning : not owned by root: /var/spool/postfix/lib/libdb-3.3.so
postfix/postfix-script: warning : not owned by root : /var/spool/postfix/usr
postfix/postfix-script: warning : not owned by root : /var/spool/postfix/usr/lib
postsuper: Renamed to match inode nunmer: 230 messages
postsuper: warning: QUEUE FILE NAMES WERE CHANGED TO MATCH INODE NUMBERS
postfix/postfix-script: starting the Postfix mail system

What are these warning messages?

ann_tulip18 07-09-2003 10:08 PM

I tried to send mail on my own email add using one of the computers here (outlook) however I still dont receive the email.

What will i do next?

Sorry if I have so may questions.

MasterC 07-09-2003 10:08 PM

Well, we can keep doing this if you'd like, eventually we should get all the permissions back. Another option is for you to use the upgrade option in the postfix source, this will go through and install and set correct permissions on all the new packages when installing postfix.

Cool

ann_tulip18 07-09-2003 10:17 PM

So you mean the best option is to reinstall the postfix?? I will try to set the permission like what you have taught to me.. I hope it will work!!

THANKS! :)

mfread 07-09-2003 10:19 PM

Well you could spend all this time, energy and heachache trying to fix your space issue by finding the space hog and figuring out how to uninstall it. Or you just ghost to a larger drive... ghost will resize the partitions to scale to the new drive automatically and you have the chance to adjust it at that point.

Or possibly a better fix for you might be to copy out all the mail spools, then google clarkconnect, download the 1.3 ISO, this is a redhat based distro that uses utilities like apt by default, is specifically designed to run as a mailserver/gateway and doesn't install a whole lot more than is needed to perform these functions. It also uses postfix by default rather than the historically bug ridden sendmail. You can perform the simpliest of administration on the local lan by point a browser at: https://mailserverip:81.

It has the advantage of being the only cookie cutter mail/web/ftp/gateway application distro I know of that doesn't overwrite manual changes or require you edit templates. It uses the same directory structure any redhat system uses.


It will take up to an hour to install if you've never done it before and have 50 users or so. You might lose the mail that is sitting on your server right now if you don't know how to move the mail spools back in place but that might not being to compare wit the mail you lose being down.

ann_tulip18 07-09-2003 10:50 PM

I have set all the permissions. Thanks to you! About space hog, what is it?? I guess I'll go with that option, uninstall what is eating up my space.

ann_tulip18 07-09-2003 11:57 PM

I am trying to uninstall nautilus ( i will not use it) But theres un error message again:

error : removing these package s would break dependensies:
nautilus = 1.0.6 is needed by nautilus-mozilla-1.0.6-15
libnautilus.so.0 is needed by nautilus-mozilla-1.0.6-15

So i tried to uninstall nautilus-mozilla-1.0.6-15 but it displayed again an error message

error: removing these packages would break dependencies:
nautilus-mozilla is needed by nautilus-1.0.6.15

How will i remove these applications????

MasterC 07-10-2003 12:29 AM

Remove them both at the same time, or --force it.

Cool

ann_tulip18 07-10-2003 02:28 AM

I have removed all the applications that I think it is not used by the server, however it seems not to work out.

What else can I do?


All times are GMT -5. The time now is 03:48 AM.