-   Linux - Newbie (
-   -   Running commands (

linuxnewbie001 08-01-2003 04:06 PM

Running commands
I know this is really stupid, but anyway:

When instructions say "run the df command and check the output", what do I do?

(I mean, a literal step-by-step process)

Proud 08-01-2003 04:13 PM

Which window manager are you using?
Basically go through the menu to Terminals or Consoles and pick your favourite, then try the command.

Or press Ctrl+Alt+F1 to F6 for command line login screens.

bitpicker 08-01-2003 04:17 PM

I take it you're in some windowed environment like KDE.

You can either open the program memnu and open a console from there, or you can hold Ctrl and Alt and press F1 (or F2 ... F6). The first will open a command line window, the other option will send you to a full screen version of the same thing.; there you will also have to log in new.

Whichever option you use, you will be at a command line now, and you can simply type df then Enter. You'll see the list of your partitions.

After that you can either type exit or close the window you opened, or if you switched to a full-screen console you can return to the GUI by holding Ctrl + Alt + F7.


Skyline 08-01-2003 04:17 PM

Echoing what Proud said

Open a terminal



then type your Root password

then type

df -h

(other commands follow a similar procedure - ie - su to Root user - then type command)

linuxnewbie001 08-01-2003 04:18 PM

many thanks

Proud 08-01-2003 04:27 PM

Btw there's also KDiskFree in the KMenu -> Applications -> Monitoring (for Mandrake at least) which is KDE's nice visual layout of the result of df -h in the terminal. Or kdf ;)

linuxnewbie001 08-01-2003 04:28 PM

/dev/hda3 is my boot partition. I am trying to copy the Boot Sector onto a floppy. I am logged in as root and I my floppy drive is mounted, but what is wrong with the following command?

$ dd if=/dev/hda3 of=/mnt/floppy/linux.bin bs=512 count=1

I get: dd: opening `/dev/hda3': Permission denied

All times are GMT -5. The time now is 01:10 AM.