LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Ruba-dub-Grub, my PC is a dud. PC launches Grub but should not, I think. (https://www.linuxquestions.org/questions/linux-newbie-8/ruba-dub-grub-my-pc-is-a-dud-pc-launches-grub-but-should-not-i-think-775234/)

Robert.Thompson 12-12-2009 06:34 PM

Ruba-dub-Grub, my PC is a dud. PC launches Grub but should not, I think.
 
Hello:

I used the Mepis 8.0 to install linux to my external USB hard drive and, to the best of my meager knowledge, I told the installer to put 'everything' on the external disk, to boot from root and to not us the MBR on the internal disk. When I rebooted, the system hung.

I reinstalled Mepis but this time I gave up on the idea of booting from the external disk so I told the installer to use the MBR thinking that this would give me a 'dual-boot' system. It didn't. Instead it gave me a 'no-boot' system.

Here are the results of this stellar installation:

1) Can only start XP by booting with a Gparted iso CD.
2) Can only start Linux with the Mepis iso CD.
3) The SUSE 11.2 iso CD will not boot at all.

On start up, with the external plugged in and no Gparted used, I get a blank screen with a blinking cursor living in the top left-hand corner. This seems to last for ever, although I have never tried it. :)

On start up without the external plugged in and no Goarted used, I get:
Grub Loading stage 1.5
Grub Loading, please wait...
Error 21

Using Gparted with or without the external disk plugged in gives various error msgs depending on which option I choose other than the 'Windows/Linux (sda1 Internal Drive)' option.

Is there a way to:
1) install Mepis on the external disk.
2) create a dual-boot that works.
3) stop this Grub issue.

Thanks for any ideas,

lupusarcanus 12-12-2009 07:04 PM

More info needed.
1.) What did you install to your internal disk? A full MEPIS installation, or just the GRUB? How did this go?
2.) GParted error details.

Robert.Thompson 12-12-2009 07:31 PM

Hello:

I just selected the option to use the MBR. I installed everything else on the external, I believe.

Gparted with no extrenal drive connected:
1) Linux - USB Drive:
Booting
root (hd1,0)
Error 21: Selected disk does not exist
Press any key...

2) Windows / Linux (sda1 Internal Drive):
this option successfully launched XP

3) Linux - sda2 (sda2 - Internal Drive):
bootnoverify (hd0,1)
makeactive
Error 12: Invalid device request
Press any key...

Gparted with external drive connected:
1) Linux - USB Drive:
just blew up and said something about checksum and then went into Bios Setup

2) Windows / Linux (sda1 Internal Drive):
rootnoverify (hd0,1)
makeactive
chainloader +1
Error 13: Invalid or unsupported executable format
Press any key...


2) Linux - sda2 (sda2 - Internal Drive):
rootnoverify (hd0,1)
makeactive
chainloader +1
Error 13: Invalid or unsupported executable format
Press any key...

These were all the possibilities.

lupusarcanus 12-12-2009 07:46 PM

GRUB uses the configuration files located in your installation of Linux. Without these commands, GRUB has no clue what to do. Especially because the GRUB configuration files located in the internal hard drive installation contain incorrect information.
You should:
1.) Use the MEPIS livecd (or any Linux livecd) and reinstall GRUB to your internal hard drive. Do this without your external hard drive connected. (Google around for how-to install GRUB, or wait around for an LQ member to help).
2.) Connect your external hard drive; and have a look as to what drive letter (hda2, sda1), and manually create an entry in your menu.lst for it.
3.) Done.

Hope I helped!

yancek 12-12-2009 07:57 PM

If you want Mepis on the external, install Mepis to sdb (which is what your external should be called) and to the master boot record of sdb, not to the root partition, sdb1. Set your boot priority as CDROM first, external second, harddrive third. Then if you have no bootable CD in the drive and your external attached, Mepis will boot. If you have no bootable CD in the drive and your external not attached, your windows on the internal will boot.

If on your second effort your installed Grub stage1 to the internal drive master boot record, you will need to repair your windows mbr. With xp installation disk, go to Recovery mode and run commands: fixmbr and then fixboot. If you don't have a full installation CD, it won't work as the necessary files are not on a Recovery CD.

Load your Mepis CD, do not click the Install icon, and open a terminal, login as root (type su or su -) probably won't need a password but I don't use Mepis so I'm not sure. If you can do this, post the output of the fdisk -l command (lower case Letter L) to display your partition information.

I forgot to mention that the Error 21 with the external not connected is as it should be. You have stage1 of Grub on the internal mbr pointing to the rest of the Grub boot files which are on the non-attached external.

Robert.Thompson 12-12-2009 09:06 PM

Hello:

Here is the fdisk -l info:

Disk /dev/sda1: 160.0GB
Device Boot <snip> ID System
/dev/sda1 * 7 HPFS/NTFS
/dev/sda2 5 Extended
/dev/sda3 12 Compaq Diagnostics

Disk /dev/sdb: 319.3GB
Device Boot <snip> ID System
/dev/sdb1 * 83 Linux
/dev/sdb2 82 Linux Swap/Solaris
/dev/sdb3 12 Linux


Also, I cannot get into XP anymore. Using the XP CD works until I enter 'R' for repair - sometimes I get a msg that there is no hard disk; other times it skips the disk select part and places me at a prompt where I do FIXMBR and FIXBOOT C: and then EXIT. Both commands act as if they are doing what they should but when the PC tries to boot it doesn't.

Gparted doesn't boot into XP either.

I hate to ask this but am I about to have a 100% linux Lenovo X61 LapTop?

lupusarcanus 12-12-2009 10:02 PM

I would try to reinstall the GRUB first. If after that you can't boot into XP then you might have a linux laptop. But try that first.

Robert.Thompson 12-13-2009 07:38 AM

Hello:

I did a Grub install, from info on the net, but PC still didn't boot. Basically, XP could no longer find the internal disk drive.

So,I gave up on my career as a windows/linux repairman and used my Lenovo Rescue disk to restore from my last backup - it is doing this now. ( I feel like I am a 'time traveler' off to explore the past! :) )

Well, the restore did absolutely nothing to help with the boot problem - still get the Grub error.

When I do an XP repair, without the external connected, I get a msg that says no disk found and it reboots. When I do the same thing with the external connected, it skips the 'select drive' option (usually # 1) and goes directly to the c: prompt.

Before I do a restore 'to factory defaults', does anyone know if that will make the PC work? Is there any other options available?

For what it is worth, I am running the Hard Disk Diagnostic program from the Bios menu - so far it is happily perking along but will take hours to finish.

I can boot into linux using the Mepis CD - is there anything I can do from there to get my internal hard disk working again?

I got my SUSE 11.2 to boot. Going through the install I get to the partitioning part and see this for sda:

/dev/sda1 130.55GB Linux native NTFS Preload
/dev/sda2 1.0KB Linux native
/dev?sda3 4.52GB Linux native FAT Service001


Does the /dev/sda2 having only 1 kilobyte have any significance to my problem?

Robert.Thompson 12-15-2009 06:27 AM

Hello:

Well I can't believe it but I had to format my C:\ drive and re-install windows!

I would have thought that if you screwed up your windows installation with linux that you could repair it using linux - maybe in the next distribution...

Linux has disappointed me.

syg00 12-15-2009 06:48 AM

It probably could have be fixed relatively easily. Such are the vagaries of mixing disparate software with a little impatience.

As it happens I think most of the popular distros do an appalling job of installing in multi-disk environments - especially where external disks are involved.

Robert.Thompson 12-15-2009 06:59 AM

So, where the hell were you when I needed you!!!!! :)

I don't know how long to wait for replies here. It seems that they come often just after posting a thread and then become very sporadic.

Don't get me wrong, I have appreciated every bit of advice I have received but when I got to the office Monday I had little choice but to move on.


All times are GMT -5. The time now is 11:00 PM.