LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2016, 05:04 AM   #1
QWE123
Member
 
Registered: Nov 2014
Posts: 55

Rep: Reputation: Disabled
rsyslog problem


I got the below messages in the log .

imuxsock begins to drop messages from pid due to rate-limiting
imuxsock lost xxx messages from pid due to rate-limiting


I tried added the below line to rsyslog.conf , then the size of the log will be growth very fast.

$SystemLogRateLimitInterval 0
$SystemLogRateLimitBurst 0
$IMUXSockRateLimitInterval 0
$IMUXSockRateLimitBurst 0

I tried to change it to below , then the openldap service will run slow .

$SystemLogRateLimitInterval 2
$SystemLogRateLimitBurst 50

Would advise what can I do for this case , what setting should I use so that no messages will be prompt to the log ?

thanks

Last edited by QWE123; 10-12-2016 at 05:13 AM.
 
Old 10-12-2016, 09:57 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 22,320

Rep: Reputation: 6026Reputation: 6026Reputation: 6026Reputation: 6026Reputation: 6026Reputation: 6026Reputation: 6026Reputation: 6026Reputation: 6026Reputation: 6026Reputation: 6026
Quote:
Originally Posted by QWE123 View Post
I got the below messages in the log .

imuxsock begins to drop messages from pid due to rate-limiting
imuxsock lost xxx messages from pid due to rate-limiting

I tried added the below line to rsyslog.conf , then the size of the log will be growth very fast.

$SystemLogRateLimitInterval 0
$SystemLogRateLimitBurst 0
$IMUXSockRateLimitInterval 0
$IMUXSockRateLimitBurst 0

I tried to change it to below , then the openldap service will run slow .

$SystemLogRateLimitInterval 2
$SystemLogRateLimitBurst 50

Would advise what can I do for this case , what setting should I use so that no messages will be prompt to the log ?

thanks
As with several of your other threads, you NEED TO START DOING YOUR OWN RESEARCH. Putting the error into Google leads you to:
http://www.rsyslog.com/tag/rate-limiting/

...the rsylog site, which tells you how to set/test these things, and how to put a 'failsafe' file in place to ensure you don't drop any messages. In short, there is no 'perfect' answer, since it depends on how fast/much things are logging. Adjust the settings, and keep trying until you get it right.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rsyslog template problem ! shipon_97 Linux - Newbie 1 08-01-2016 09:04 AM
[SOLVED] rsyslog and log rotate problem suprstar Linux - Server 3 02-26-2012 07:09 AM
rsyslog problem on rhel5 pardoxx Linux - Newbie 1 01-18-2012 11:02 AM
Problem when autostarting rsyslog gatsby Linux - Software 6 09-25-2008 11:05 AM
Problem I faced in using rsyslog prakash.akumalla Linux - Software 0 06-26-2008 04:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration