-   Linux - Newbie (
-   -   RPM search as user fails and works with root user (

kais1 08-27-2012 03:18 PM

RPM search as user fails and works with root user
Hai all,

We have Linux RHEL 4 Itanium installed on 2 servers.

[oracle@db1 ~]$ uname -a
Linux servername 2.6.9-55.EL #1 SMP Fri Apr 20 16:30:19 EDT 2007 ia64 ia64 ia64 GNU/Linux

Any clue ?


chrism01 08-27-2012 08:37 PM

1. if you want non-root user to be able to run those rpm cmds, you'll want them IN the rpm group.

open("/var/lib/rpm/__db.001", O_RDWR) = -1 EACCES (Permission denied)

2. The above may also be the cause of

.... ... No such file or directory
... ... No such file or directory

OR they really don't exist ie are not installed

kais1 08-28-2012 02:33 PM

Thanks Chris.

1.We have the files missing in node 2 too, but the same command works fine in node 2 as non-root user


chrism01 08-28-2012 06:53 PM

There's something seriously messed up with your rpm SW, any user should be able to

rpm -qa | grep glibc
I just double checked with a non-priv user on one of my systems; no problem...


rpm --rebuilddb
I'd also x-check the ownerships, perms & selinux (not on RHEL4 though) settings on both systems for the rpm SW & rpm db
On my RHEL5 & RHEL6 systems, I'd check the /var/lib/rpm dir contents.


NB: do the rebuilddb after checking/setting owners/perms etc.

BTW: you do know RHEL4 went out of regular support in Feb ?

kais1 09-01-2012 06:15 AM

Thanks Chris. I tried rebuilding the RPM, but issue still exists.


chrism01 09-02-2012 06:11 AM

So, did you add the user to the rpm group?

kais1 09-02-2012 06:35 AM


Originally Posted by chrism01 (Post 4770525)
So, did you add the user to the rpm group?

Yes . Chris. I tried the same , but still not working. Wondering what else could be the problem.


chrism01 09-02-2012 06:22 PM

I guess you're going to have to slog through checking the working user against the non-working one..
Check the login files line by line, ownerships, groups, perms, acls ...

All times are GMT -5. The time now is 06:30 PM.