LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   RPM install problem (https://www.linuxquestions.org/questions/linux-newbie-8/rpm-install-problem-91704/)

Killah 09-11-2003 02:56 PM

RPM install problem
 
Hi, I have some problems with RPM instals

when I'm in root and want to start an rpm install, my pc don't do anything

-->

[Root@Local host killah] rpm -ivh filename.rpm
(enter)
and there he stops :(

I'm using redhat linux 9.0
need help !!
thx Pieter

daveo 09-11-2003 03:04 PM

Re: RPM install problem
 
Quote:

Originally posted by Killah
Hi, I have some problems with RPM instals

when I'm in root and want to start an rpm install, my pc don't do anything

-->

[Root@Local host killah] rpm -ivh filename.rpm
(enter)
and there he stops :(

I'm using redhat linux 9.0
need help !!
thx Pieter

Try rpm -i filename.rpm

Hope it helps, but you've already try that huh ?

Killah 09-11-2003 03:06 PM

Yes I Do , is there nothing else i can do ??

thx for reply

daveo 09-11-2003 03:11 PM

Re: Re: RPM install problem
 
Quote:

Originally posted by daveo
Try rpm -i filename.rpm

Hope it helps, but you've already try that huh ?

Hmm it's strange, if you already post this in the redhat mailgroups?
Maybe the redhat package manager is corrupt ? or do other rpm file work properly ?

Killah 09-11-2003 03:19 PM

No, I can't execute all Rpm files ..
Dammmmm

daveo 09-11-2003 03:26 PM

Quote:

Originally posted by Killah
No, I can't execute all Rpm files ..
Dammmmm

You've also checked with df -h to make sure that the disk isn't full ?

Killah 09-11-2003 03:30 PM

No that isnt the problem

daveo 09-11-2003 03:44 PM

Quote:

Originally posted by Killah
No that isnt the problem
Hmm is the rpm database ok?

Database maintenance:
rpm -i [--initdb]
rpm -i [--rebuilddb]

already check that ?
What version of rpm are you using ?

Killah 09-11-2003 04:03 PM

I dunno i'm a very newbie
how do you see that?

Killah 09-11-2003 04:05 PM

[killah@localhost killah]$ su
Password:
[root@localhost killah]# rpm -i [initdb]
error: File not found by glob: [initdb]
[root@localhost killah]# rpm -i [rebuilddb]
error: File not found by glob: [rebuilddb]
[root@localhost killah]#

daveo 09-11-2003 04:07 PM

Quote:

Originally posted by Killah
[killah@localhost killah]$ su
Password:
[root@localhost killah]# rpm -i [initdb]
error: File not found by glob: [initdb]
[root@localhost killah]# rpm -i [rebuilddb]
error: File not found by glob: [rebuilddb]
[root@localhost killah]#

Please do man rpm ...

I'll get back to you, I need to update some pages ....

Killah 09-11-2003 04:11 PM

ok thx in advance

daveo 09-12-2003 01:12 AM

Quote:

Originally posted by Killah
ok thx in advance
Ok I'm done, well try this the generate a new package database:

rpm --initdb

Hope this helps ...

Killah 09-12-2003 06:35 AM

[root@localhost root]# rpm --initdb
[root@localhost root]# rpm -initdb
[root@localhost root]#
[root@localhost root]#


don't do anything i guess

Killah 09-12-2003 06:39 AM

[root@localhost root]# cd /home/killah
[root@localhost killah]# ls
getting.started.rpm School winedefault.reg
msn wgi-1.13-src.tgz
rp8_linux20_libc6_i386_cs2.bin wgi.rev
[root@localhost killah]# rpm -ivh getting.started.rpm
warning: getting.started.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing... ########################################### [100%]
1:rhl-gsg-en ########################################### [100%]

ok this is what i get when i install an rpm right now

where is it installed noww???

sorry i'm a very very very noob :)


All times are GMT -5. The time now is 07:36 AM.