LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-25-2003, 07:11 PM   #1
taylortbb
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake
Posts: 21

Rep: Reputation: 15
RPM Dependncy Problems


I have had numerous problems with this, it seems that no matter what I go to install there is always somthing that is not there, Is there somthing that needs installing that for some reason didn't come with my Linux?

Technical Information
-----------------------
Mandrake Linux 9.2
Installed via Network
Pentium 133 w/ 64 megs RAM

The 2 biggest offenders to this problem are (following are error messages)
This was after running updater, same message for every sigle package listed
Sorry, the following package(s) can't be selected:
____file name, example:kdebase-kdprintfax-3.1.3-79.1.92mdk.i586____ (due to unsatisfied rpmlib(CompressedFileNames) <= 3.0.4-1)

This is from almost almost all RPMs I download from the net:
Some package requested cannot be installed:
___file name, example:amsn-0.81-1.i386___ (due to unsatisfied /usr/bin/tclsh)
do you agree ?

Thank You very much to anyone who helps, I am a , only have 10-15 hours of useage time, a bit annoying after being the the person with all the answers for windows, but truth is I hate MS, again ty
 
Old 11-25-2003, 07:56 PM   #2
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
Quote:
___file name, example:amsn-0.81-1.i386___ (due to unsatisfied /usr/bin/tclsh)
what happens when you try to solve this dependency by installing /usr/bin/tclsh ?
 
Old 11-25-2003, 10:54 PM   #3
taylortbb
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake
Posts: 21

Original Poster
Rep: Reputation: 15
This was also supposed to cover the question, where would I go aobut getting it, I aven't been able to find it no matter how much searching I've done, is there a central palce to download this sort of thing?

Last edited by taylortbb; 11-25-2003 at 10:56 PM.
 
Old 11-26-2003, 03:42 AM   #4
knl
LQ Newbie
 
Registered: Nov 2003
Posts: 5

Rep: Reputation: 0
Thumbs up

if you are using Mandrake 9.2 use urpmi or rpmdrake tools theese tools should help you solve your dependency problems they will let you know what additional rpms to install to solve dependency issues. urpmi and rpmdrake will automatically install the dependecies if the rpms needed are listed in your urpmi database. The link below should teach you how to use urpmi.

http://www.urpmi.org/en/mini-howto/
 
Old 11-26-2003, 09:20 AM   #5
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
rpmfind.net is good alsong as you have an rpm based distro...
also google.com/linux is a LIFE saver !

ohh, and while im handing out vital linux life line links... sourceforge.net
 
Old 11-26-2003, 09:47 PM   #6
taylortbb
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake
Posts: 21

Original Poster
Rep: Reputation: 15
Thank you very much, however one package I needed is for SuSe only altough the program I am trying to isntall is supposed to be Mandrake compatible lol, oh well
 
Old 11-27-2003, 07:59 PM   #7
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
when a package says is for a certain distro, provided your distro is of a similar age it will usually work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RPM problems King of Japan Red Hat 4 01-27-2005 12:04 AM
RPM problems bloodfrost Linux - Newbie 6 05-06-2004 05:47 PM
rpm problems skatcat31 Linux - Software 5 02-23-2004 03:03 AM
problems with rpm talkinggoat Linux - Software 2 10-12-2003 11:02 PM
RPM Problems demonx Mandriva 2 09-28-2003 10:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration