LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   RPM dependancies (https://www.linuxquestions.org/questions/linux-newbie-8/rpm-dependancies-74952/)

james3mg 07-22-2003 04:13 PM

RPM dependancies
 
I downloaded an .rpm package I wish to use, but when I try to install it, it checks dependancies and says it needs but doesn't have:

libvgagl.so.1
libvga.so.1
libwx-gtk-2.3.so.2

I searched google, and can find what they do, but not how to get them. I looked on all three redhat cds, but still can't find these packages. How do I get them?

Thanks
Michael

Pcghost 07-22-2003 04:27 PM

Enter one of the names in the search box at
http://www.rpmfind.net

Sometimes it can find the package that contains the files.

james3mg 07-22-2003 04:46 PM

ok, that took care of the first 2, but it can't find anything for

libwx_gtk-2.3.so.2

Any idea what this is or where I can find it?

Thanks

DrOzz 07-22-2003 05:01 PM

wxGTK-2.3.3

Mega Man X 07-22-2003 05:02 PM

Hi james3mg!!!

Yeah, dependancies are a big problem. That's why most of the peoples don't like rpm packages. Which program are you trying to install?. I mean, because, have you heard of apt-get?

http://freshrpms.net/

It's a program that download, check and install programs with all it's dependancies. If I was you, I'd give it a try. For example, let's suppose you want to install mplayer... you would only need to type

apt-get install mplayer

at the terminal. All needed packages would be downloaded and installed. Again, if you are planning to stick using rpm's, apt-get is your best shot. Otherwise, source compiling is more effective.
Well, it's just a tip. I remember how painfully it was to install rpm's ;)

Good luck!

james3mg 07-23-2003 10:45 AM

GREAT...I'll give that a shot. Sounds perfect. Thanks so much

Michael

james3mg 07-23-2003 03:07 PM

OK, can't get apt-get to work. I installed the RPM (fortunately no unresolved dependacies this time), and it worked, because if I type apt-get on the commandline now, it gives me the switches.

Now the package I'm trying to install is on my zip drive as bochs-2.0.2.i386.rpm. If I type rpm -i bochs-2.0.2.i386.rpm, it tells me:

E: Couldn't find package libwx_gtk-2.3.so.2

So I type apt-get install bochs-2.0.2.i386.rpm, and it says it can't find bochs-2.0.2.i386.rpm. I typed man apt-get and find out you only type the name of the package after the install switch. So I type

apt-get install bochs

and it says

E: Can't find package bochs.

What am I doing wrong?

Mega Man X 07-23-2003 03:28 PM

You are doing just fine ;). Well, I would make a wild guess that you need to install wxGTK-devel to get bochs to work. Try installing wxGTK-devel and run again:

rpm -ivh bochs-2.0.2.i386.rpm

There's one more tip for apt-get. As you see, apt-get is a command line tool. There's a nice graphical tool for it called synaptic. Type at the console:

apt-get install synaptic

You can run synaptic typing synaptic at the terminal. You need to have root permissions for it. This cool tool allows you too install/remove packages and general softwares to your machine and all possibles packages to download and install thru it downloading from internet (just as apt-get, but graphicaly). When you try to install an rpm that you've got from internet, and get an error message as yours above:

libwx_gtk-2.3.so.2

I use synaptic to "try" to find what it's missing. I then typed the hole message (libwx_gtk-2.3.so.2) no results. Then I've changed a little... typed only libwx, then only gtk, till I find something that possible would match what you need. Again, my wild guess was/is to install wxGTK-devel.

Unfortunately, you can't install bochs via synaptic/apt-get ( At least, I did not find any package). So you have not done anything wrong. (although apt-get is outstanding program, not all packages are available). Anyway, it is always good to have synaptic installed to find possible missing matches and maintain a system fully operational and indeed, upgrade packages and install new programs thru it. So get synaptic and check to see if any programs (including games and emulators as gxmame...ghehe) are of interesting to you. Plus, update your distro, packages and apt-get/synaptic itselfs.

Another good way to find which package you are missing out, is to type the full error message at google as:

E: Couldn't find package libwx_gtk-2.3.so.2

It'll return possible matches to fix your missing packages. Any problem, let me know.
Good luck

Mega Man X 07-23-2003 03:37 PM

@ DrOzz

Oops...

You've already suggested wxGTK-2.3.3. Sorry buddy, I didn't see you've written it already. At least, I'm glad that I was not out of spot ;).

james3mg 07-23-2003 03:45 PM

When I type apt-get install synaptic, it says E: Couldn't find package synaptic. Do I have a bad install of apt-get?

Mega Man X 07-23-2003 03:51 PM

Odd... if you've typed really correctly, it should install...

apt-get install synaptic

anyway, try this before:

apt-get update

then

apt-get upgrade

This would upgrade and update some packages, including apt-get itselfs. Try once again apt-get install synaptic and let me know, thanks :)

james3mg 07-23-2003 03:59 PM

ok, well it's working on the upgrade part now...it says 20 minutes left. In the mean time however, I've installed several wxGTK-devel rpms, most failed, one worked (wxGTK-2.4.0...none of the devels worked). However, I still get the same module missing error when installing bochs. I guess I'll see what happens after I upgrade apt-get?

Mega Man X 07-23-2003 04:04 PM

Let's think positive and cross our fingers :). You know, we both are online and many others... Just a suggestion to the webmaster... This forum could have an online chat :D. Would be nice to have a real time support + debates on SCO and others. Perhaps I should write this to jeremy ;)

james3mg 07-23-2003 04:25 PM

The install of synaptic appears to have worked. Now to get bochs working. How can I use synaptec or apt-get to do this? apt-get install wxGTK-2.3.3 doesn't do anything.

Mega Man X 07-23-2003 04:30 PM

GREAT. no no, try running first:

synaptic

That will open synaptic. Note that synaptic has a search tab called "Find package". Type now into find package path:

wxGTK

You will actually get an even newer version :) (2.4.1 I think).


All times are GMT -5. The time now is 01:19 PM.