LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-10-2015, 01:38 PM   #1
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Rep: Reputation: 49
Root terminal: 'Granted permissions without asking for password' - Is this normal?


I am using debian 7.7 stable and when I open the root terminal it asks for the password.

But if I open it again, I get the message: 'Granted permissions without asking for password. The /usr/bin/x-terminal-emulator program was started with the privileges of the root user without the need to ask for a password, due to your system's authentication mechanism setup'.

Oh, really? Because I don't remember setting up any 'authentication mechanism setup'.
How can I change this so the root terminal always asks for the password?
Do I have a trojan already? Because I installed the OS just a few days ago.

Thanks very much.
 
Old 01-10-2015, 01:43 PM   #2
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
If it is a terminal run these commands to find who is logged on.

Code:
id
who
whoami
 
Old 01-10-2015, 01:51 PM   #3
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,848

Rep: Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952
When it asks for the password you should get an option to save password for current session or not and some other option? Sorry I can't be more accurate but I run XFCE and it works a bit differently to the bigger desktop managers.
 
Old 01-10-2015, 01:52 PM   #4
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=14, FreeBSD_10{.0|.1|.2}
Posts: 4,505
Blog Entries: 6

Rep: Reputation: 2421Reputation: 2421Reputation: 2421Reputation: 2421Reputation: 2421Reputation: 2421Reputation: 2421Reputation: 2421Reputation: 2421Reputation: 2421Reputation: 2421
See the threads here and here. Apparently you get this message when trying to run a Gnome program as root, due to gnome-keyring or cached root password.

I am not a Debian or Gnome user so cannot test it.

Last edited by astrogeek; 01-10-2015 at 01:55 PM.
 
1 members found this post helpful.
Old 01-10-2015, 02:08 PM   #5
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,249

Rep: Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431
Quote:
Originally Posted by Higgsboson View Post
I am using debian 7.7 stable and when I open the root terminal it asks for the password.

But if I open it again, I get the message: 'Granted permissions without asking for password. The /usr/bin/x-terminal-emulator program was started with the privileges of the root user without the need to ask for a password, due to your system's authentication mechanism setup'.

Oh, really? Because I don't remember setting up any 'authentication mechanism setup'. How can I change this so the root terminal always asks for the password? Do I have a trojan already? Because I installed the OS just a few days ago.
I don't THINK you have a trojan, and what you're describing may be part of your desktop GUI environment. For example, I use openSUSE and KDE. When I run YAST the first time, it'll pop up and ask me for the root password. The SECOND time I run it, it won't. While I've never looked into the 'why' or how to make it ask every time, the behavior you're describing sounds normal. Either it's saving something in your X session (a 'cookie', for lack of a better term), which says "this x session has already been granted SUDO rights", or it could be saving it as part of gksu somewhere.

You can test this by going to a normal terminal window, and typing in "gksu /usr/bin/x-terminal-emulator". That SHOULD bring up xterm with root privileges, except attached to that bash shell. Exit that shell, and try it again...it should prompt a second time. Note that this is UNTESTED! If things go back to normal when you reboot, then you're probably fine (but if you DO suspect a trojan, please scan and check!!!)

EDIT: both 273 and astrogeek beat me to the same conclusions.
Quote:
Originally Posted by veerain
If it is a terminal run these commands to find who is logged on.
Code:
id
who
whoami
And how do ANY of those commands tell the OP if they have a trojan??? Or address their question, which is "how to get it to prompt every time, and/or is this normal?"
 
1 members found this post helpful.
Old 01-10-2015, 02:59 PM   #6
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,896

Rep: Reputation: 352Reputation: 352Reputation: 352Reputation: 352
I also use Debian 7.7. When I tried the root terminal just now, under the text box for password entry, there is a small box defaulted to check mark, and the legend Remember Password.

Uncheck the box.
 
Old 01-10-2015, 03:03 PM   #7
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by veerain View Post
If it is a terminal run these commands to find who is logged on.
id
who
whoami
These are interesting commands. I didn't know them.

The commands must be useful if there are lots of people using the same computer. Thanks dude!
 
Old 01-10-2015, 03:05 PM   #8
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by 273 View Post
When it asks for the password you should get an option to save password for current session or not and some other option?
Yes, but that's the weird thing. I never asked to save the password for the current session.
 
Old 01-10-2015, 03:07 PM   #9
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 6,848

Rep: Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952Reputation: 1952
Quote:
Originally Posted by Higgsboson View Post
Yes, but that's the weird thing. I never asked to save the password for the current session.
Sounds like you could have "added it to the keyring" or whatever the option is called. astrogeek gives some links above which may be useful to you in that regard.
 
1 members found this post helpful.
Old 01-10-2015, 03:38 PM   #10
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by astrogeek View Post
See the threads here and here. Apparently you get this message when trying to run a Gnome program as root, due to gnome-keyring or cached root password.

I am not a Debian or Gnome user so cannot test it.
Ok, so this answers my question.
I am using the gnome shell on debian.
From the link, one of the members say 'this simply happens when you try to run GUI apps from a root terminal. It is standard because ideally no GUI apps should be run as root. The proper way to run them as root is to use the gksudo command instead'.

I had previously run the gparted GUI as root. This must've then put the root password into a cache.
To prevent this, if I want to open a GUI application from the root terminal, I should always prefix it with 'gksudo'.

Well, that's good to know.
But I don't understand why the gnome desktop would want to cache the root password to make things easier for me. Gnome should leave the root password alone IMO.
Thanks for your reply.
 
Old 01-10-2015, 03:46 PM   #11
Higgsboson
Member
 
Registered: Dec 2014
Location: UK
Distribution: Debian 8 Cinnamon/Xfce/gnome classic Debian live usb
Posts: 508

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by TB0ne View Post
I don't THINK you have a trojan, and what you're describing may be part of your desktop GUI environment. For example, I use openSUSE and KDE. When I run YAST the first time, it'll pop up and ask me for the root password. The SECOND time I run it, it won't. While I've never looked into the 'why' or how to make it ask every time, the behavior you're describing sounds normal. Either it's saving something in your X session (a 'cookie', for lack of a better term), which says "this x session has already been granted SUDO rights", or it could be saving it as part of gksu somewhere.
Yes, you're right. If I run a GUI from the root terminal, the root password gets cached, like you say.
So I need to write 'gksudo <application name>' when opening GUI apps to prevent this.
Thanks dude.
 
1 members found this post helpful.
Old 01-11-2015, 12:15 PM   #12
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Quote:
Originally Posted by TB0ne View Post
And how do ANY of those commands tell the OP if they have a trojan??? Or address their question, which is "how to get it to prompt every time, and/or is this normal?"
Regarding the commands how does the OP knows he has logined as root. And new post by OP says, he doesn't knew these commands. And you say whats happening is peculiarity of his system.

And these commands are useful in a single system where one person uses multiple user, group ids.
 
Old 01-11-2015, 01:32 PM   #13
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,249

Rep: Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431Reputation: 4431
Quote:
Originally Posted by veerain View Post
Regarding the commands how does the OP knows he has logined as root.
He DIDN'T log in as root, and said so. Did you not read the OP's post?
Quote:
And new post by OP says, he doesn't knew these commands.
Which doesn't matter, since they in NO WAY had anything to do with helping the OP answer their questions.
Quote:
And you say whats happening is peculiarity of his system.
No, I didn't. I very specifically said that it is NORMAL, and answered one of the OP's questions, and gave them ideas on what else to do to verify things, to make sure they didn't have a trojan. There is nothing 'peculiar' about their system. Please try to read and understand the question and the answers before posting.
Quote:
And these commands are useful in a single system where one person uses multiple user, group ids.
Their use is VERY limited, and for the purposes of THIS thread, USELESS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can start xterm/Terminal as root but not as normal user Keith Hedger Linux From Scratch 3 05-21-2013 06:35 AM
How could normal user obtain root password or change root password ckamheng Debian 18 02-18-2009 11:28 PM
Password Recovery in Edubuntu 7.04 - In Terminal, Root Login : su , password : ????? farhannaeem13 Linux - Security 3 11-30-2007 10:59 AM
How to disable password changing permissions to normal users ? toraghun Linux - Newbie 14 11-17-2005 11:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration