LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Root password not working in GUI (https://www.linuxquestions.org/questions/linux-newbie-8/root-password-not-working-in-gui-703306/)

methoxcy 02-09-2009 05:49 AM

Root password not working in GUI
 
Im need some help regarding to this problem, when i logged my root password in terminal its working but if i hit my password in my control center its not working anymore,

command:/usr/sbin/drakconf.real
password:****

this dialog box need my root password but if i hit my password "incorect password" im using mandriva 2007.

what do you think??is this some kind of virus or what???
need help... tnx..

General Failure 02-09-2009 05:55 AM

Have you tried your user password? Maybe Mandriva uses sudo, like the buntus do - this would require you to enter your user password here.

linuxlover.chaitanya 02-09-2009 05:56 AM

Most of the distors these days disable root logins via GUI for security reasons. If you need to be admin use sudo. That will grant you temporary super user permissions and once you are done with your admin work you can exit it. This will help you keep your system safer from unintentional deletion of files that are required by system and other such instances.

methoxcy 02-09-2009 08:46 PM

Root password error
 
The action you requested needs root privileges. Please enter root's password below.

Command: /usr/sbin/drakconf.real
Password: ***


this is the complete details regarding the dialog box that appeared in my screen. but if i hit my root's password "Incorrect password" i already tried my admin password still then same error.

linuxlover.chaitanya 02-10-2009 12:35 AM

You can use sudo to run the command if you need super user privileges. That will need your own user password and not root password.

methoxcy 02-10-2009 01:38 AM

RE:Root Password not Working in Gui
 
PAM-1.0

auth sufficient pam_rootok.so

#auth sufficient pam_wheel.so trust use_uid

#auth required pam_wheel.so use_uid

auth include system-auth
account include system-auth
password include system-auth
session optional pam_xauth.so
session include system-auth


This is the data inside of my /etc/param.d/su

Is there something wrong???

I already test my SU command but incorrect password but if i logged directly as a root my password is working very well.and also im already member of wheel group


All times are GMT -5. The time now is 03:40 PM.