-   Linux - Newbie (
-   -   RHEL5 - (

danpd 11-18-2010 07:33 AM

Hi All,

I'm trying to configure PAM on a RHEL5 system.
I put in system.auth
password requisite retry=3 maxrepeat=1 ucredit=0 ocredit=0 minlen=9 dcredit=4 dcredit=-1 reject_username

I have problem with maxrepeat parameter because the parameter does not seem to work (i can create password with 2 same consecutive characters)

Can you help me?

Thanks in advance

sysslack 12-08-2010 05:00 PM

I have tried it on centos and it worked on my system. It is the normal user that can't set a password with more than 3 same characters/digits in a row, if he does then he get this message:
BAD PASSWORD: contains too many same characters consecutively

This may be of importance!!!
These modules may be stacked, or placed upon one another, so that multiple modules are used. The order of a module stack is very important in the authentication process, because it makes it very easy for an administrator to require that several conditions exist before allowing user authentication to occur.
Maybe this could be of help :

kvijayan 02-09-2012 06:07 AM

I am facing the same problem on Debian lenny. I think it has to do with the version of the pam_cracklib. When I do "man pam_cracklib", I am not able to see the maxrepeat option.

However, things work fine on another the ubuntu 11.10 machine.

All times are GMT -5. The time now is 03:31 AM.