LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-09-2003, 03:14 PM   #1
Arenba
Member
 
Registered: Sep 2003
Location: India
Distribution: Red Hat 8
Posts: 51

Rep: Reputation: 16
RH9 Squid Problem?


Hi,
I am a newbie. I had no problems installing and running Squid on RH8. But it doesn't seem to work on RH9.
Reports some problems on a file in /etc/init.d/rc.5 (or something). I checked - naturally, I couldn't make heads or tails of it. I reverted back to RH8.
Can anybody please help? Is it worth shifting over to RH9?
Aka.

Last edited by Arenba; 09-13-2003 at 07:36 AM.
 
Old 09-18-2003, 11:23 AM   #2
browny_amiga
Member
 
Registered: Dec 2001
Location: /mnt/UNV/Mlkway/Earth/USA/California/Silicon Valley
Distribution: Kubuntu, Debian Wheezy/Jessie Stable, Windoze 7
Posts: 596

Rep: Reputation: 36
Thumbs up

I generally though, think that RH9 is better than RH8, old rule:
Never trust a zero version (i.e. 7.0 , 6.0)
I had some funny business with RH8, like odd spaced console fonts, strange characters that you could not recognize etc..
I am using RH9 for almost 4 months now and don't think of switching back a bit.
One thing to mention is that Wine breaks big time on RH9 and I *think* the newest version of it 200309011 fixed it now, but not sure yet.
If you are using wine, don't go to rh9.

Squid works on RH9, had to do my RedHat Certified Engineer on it, that is why I know. I would never use this proxy (or any other) normally...
There is some funny buiness with the format of the access restriction in the config file...

What error do you get exactly?
 
Old 09-19-2003, 12:44 AM   #3
Arenba
Member
 
Registered: Sep 2003
Location: India
Distribution: Red Hat 8
Posts: 51

Original Poster
Rep: Reputation: 16
Smile

Sorry, but I forgot to note down the error message I got. I have to reinstall RH9. (I am back to RH8 again). So I will let you know later on.

I don't use Wine. I am trying not to. :-)

Thanks for the reply. Will get in touch with you soon.
 
Old 09-19-2003, 07:47 AM   #4
Arenba
Member
 
Registered: Sep 2003
Location: India
Distribution: Red Hat 8
Posts: 51

Original Poster
Rep: Reputation: 16
This is the error message I get when I try to run Squid.
(in RH9 Squid version 2.5.STABLE1)
init_cache_dir /var/spool/squid... /etc/init.d/squid: line 162: 1285 Aborted
$SQUID -z -F -D 2>/dev/null
Starting squid: /etc/init.d/squid: line 162: 1286 Aborted $SQUID $SQUID_OPTS 2>/dev/null

This happened during a standard installation.
When I try to create cache dirs (squid -z) or run squid, it gives this error

FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'
Squid Cache (Version 2.5.STABLE1): Terminated abnormally.
CPU Usage: 0.020 seconds = 0.010 user + 0.010 sys
Maximum Resident Size: 0 KB
Page faults with physical i/o: 389
Aborted

In RH8 (Squid 2.4.STABLE7), I did not have a problem. I had included Squid (default rpm installation) and it ran well. I wanted to enable delay pools this time. So I tried to manually configure it (was my first compilation, by the way....never ./configure(d) before). Of course, I went through a few documentations before compiling Squid and then tried it. Didn't work.
Then I installed RH9. It gave me the errors shown above. In RH9, I couldn't even get Squid working through a standard default installation (in RH8 it did).
I suspect something wrong in the path configuration. In default installations, squid usually installs itself in /etc/squid, whereas manually, it defaults to /usr/local/squid. So I guess there must be something I missed. (I really tried to work it out and I am exhausted now!!).
Also, are there some specific compilers needed when it is run manually? I don't know, so I just installed the standard compilers (gcc and all that stuff). If somebody can give me a list of all the compilers needed specifically(and maybe its clones), I'd be very grateful.
Now, I don't know what to do. I can switch back to RH8 with the default squid installation (that works). But I really need the "delay pools" feature. So I guess I'll have to hang around for a little while....
:-)

Note: I had chown(ed) all squid-related dirs to squid too. In squid.conf, I set the cache_effective_user & group to squid. I used the default path for logs and cache and also tried using a user-defined path. Zit !!!

Thanks for the interest.

Edit:- I had referred to www.tldp.org., howto section (Bandwidth limiting HOWTO)

Last edited by Arenba; 09-19-2003 at 07:57 AM.
 
Old 09-20-2003, 01:09 AM   #5
Arenba
Member
 
Registered: Sep 2003
Location: India
Distribution: Red Hat 8
Posts: 51

Original Poster
Rep: Reputation: 16
Hi Browny_Amiga

Seemed to have finally got it working. I did it in RH8 though using Squid 2.4 STABLE7. There are still some things to be done, basically to add some sort of start up script or something/somewhere. Remember, I am a newbie - I just got on to Linux a couple of weeks back !! But the main .conf file up and working - and believe me it's satisfying !!!!
Now I am feeling sleepy ...........
Thanks a bunch for your interest.
 
Old 09-20-2003, 03:33 AM   #6
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Not much help now but from memory the visible hostname eror could have gotten round by adding to your conf

visible hostname whatever_name_I_want

and you'd probably have been good to go
 
Old 09-20-2003, 03:40 AM   #7
dunmarie
Member
 
Registered: Aug 2003
Location: Johannesburg, South Africa
Distribution: RedHat 9.0; SmoothWall Express
Posts: 43

Rep: Reputation: 15
Hi Arenba,
I am also installing Squid on RH9 and I got exactly the same error you got in post 4. I have tried using "any_name" but with no success. Can you please tell us what you did to fix the problem?
Thanks.
 
Old 09-20-2003, 06:40 AM   #8
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
When I was using it I put

visible_hostname cache.mylan.com

in to squid.conf and added an entry to the /etc/hosts file

192.168.0.2 cache.mylan.com

or whatever, although the host file bit may not be needed as like most things I setup squid just for the experience then once I had satisified myself I could get it going i dumped it. Of course it may not
solve everything but it's a start.
 
Old 09-20-2003, 07:23 AM   #9
Arenba
Member
 
Registered: Sep 2003
Location: India
Distribution: Red Hat 8
Posts: 51

Original Poster
Rep: Reputation: 16
Hi dunmarie,
Basically, I myself, have to figure out what I did. I tried soooo many things, I lost track of what I did. So I am planning to reinstall it once again.
Also, I used RH8 with Squid 2.4.Stable7(I downloaded it from www.squid-cache.org). The rpm that comes packaged with RH8 is version 2.4.Stable7-4 or so it says). I haven't been able to figure out how to even start it in RH9 with Squid 2.5.Stable1. Another question, do you specifically need to enable delay pools too? I am asking you this because, in RH8, I didn't come across any problems just to have Squid up and running using the standard rpm (without delay pools, that is).
Anyway, I will keep you posted. Right now, I don't want to confuse you (and myself) with more confusing instructions :-). Let me perform another setup and maybe things will be much clearer. Do let me know if you come across anything too.
For reference, I checked out the Bandwidth Limiting document in the howtos section in www.tldp.org
Note: About the "visible_hostname" thing, try connecting to the internet and then starting squid. But, I am not sure. Also try the input "Looking_Lost" just put in. Usually, Squid is supposed to start with the -D option. Have to check that out. Thanks - Looking_Lost :-). Glad to have your inputs on this.
 
Old 09-21-2003, 06:18 AM   #10
Arenba
Member
 
Registered: Sep 2003
Location: India
Distribution: Red Hat 8
Posts: 51

Original Poster
Rep: Reputation: 16
Hi dunmarie,
This is basically what I did.
I unzipped (or untarred, or whatever) to a tmp dir. From there, I ran this command (all in one line):
./configure --enable-delay-pools --enable-poll --enable-truncate --disable-ident-lookups --enable-removal-policies
You can add a prefix if you want it located in a specific dir of your choice. Squid defaults itself to /usr/local/squid if you don't add it. (I kept it that way).
Then I ran the make all and make install commands.
Next, I edited the squid.conf file in /usr/local/squid/etc/ (in my case, that is)
It all depends on where you want to store logs or the cache.
I changed the cache_mgr to root and cache_effective_user and group to squid.
Next, I chown(ed) all squid dirs to squid, except for the bin dir (under squid. I kept the owner as root only)
Then I chmod(ed) all squid dirs to 770.
Next, I created the cache dirs.
/usr/local/squid/bin/squid -z
To start squid,
/usr/local/squid/bin/squid -D
If you are connected to the internet already, -D is not needed.
To start squid with the -D option everytime we boot the comp., I added this line to the /etc/rc.d/rc.local file
/usr/local/squid/bin/squid -D
Normally, we start or stop squid using the command:
/etc/init.d/squid start (restart etc right??).
It doesn't work here. You have to navigate to /usr/local/squid/bin/ everytime you want to enable squid (and hence that entry in rc.local file). Maybe we have to create a script or something - I don't know.
There are so many things I don't understand. Hopefully, I'll learn more day by day. Linux is a really good system. I have forgotten about Windows for quite a while now :-). Don't forget to go to the site I mentioned in my previous posts. I picked it up from there. An example of squid.conf file is also given.
Good luck - and keep me posted if you come across anything. Right now, I am trying to fine-tune the delay pool thing (confusing little #$%$&*#).
:-)
 
Old 09-22-2003, 03:31 AM   #11
dunmarie
Member
 
Registered: Aug 2003
Location: Johannesburg, South Africa
Distribution: RedHat 9.0; SmoothWall Express
Posts: 43

Rep: Reputation: 15
Hi Arenba,
Thanks, just got it to work. My problem was with the visible_hostname. I kept on changing the word "hostname" instead of adding the hostname to the res of the line. I do find Linux sometimes a little confusing in the sense that examples is not clear. What I do like about Linux is that you have much more control than with Windows.
Good luck with your pool delay.
And thanks Looking_Lost, you put me on the right track and there was no need to add anything to /etc/host.
 
Old 03-15-2006, 10:15 AM   #12
fuseburner
LQ Newbie
 
Registered: Mar 2006
Posts: 1

Rep: Reputation: 0
visible_hostname yourhost.yourdomain

WOW!

you are totally right, a person should write the following:
visible_hostname yourhost.yourdomain

when I put that in, all was cool!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid problem yuriwalker Linux - Newbie 7 12-02-2005 06:02 AM
Squid Problem vivekthemind Linux - Security 16 10-04-2005 01:24 PM
squid problem in rh9 linus johann Linux - Newbie 22 01-31-2005 02:18 AM
how can i upgrade my squid 2.5 stable 1 to stable 3 in RH9? debloxie Linux - Networking 0 05-12-2004 09:49 PM
how can i upgrade my squid 2.5 stable 1 to stable 3 in RH9? debloxie Linux - Networking 0 05-12-2004 12:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration