-   Linux - Newbie (
-   -   RH 7.3 update causing Kernil panic (

hairysocks 05-24-2002 08:47 AM

RH 7.3 update causing Kernil panic
I'm trying to update my RH 7.1 to 7.3. I've been using 7.1 for 8 months now with no problems, but now want to update to 7.3.

The boot gets into the menu screen, and I choose "text", then the startup continues, until I get this:

NET4: Unix domain sockets 1.0/SMP for Linux NET4.0
EXT2-fs: unable to read superblock
cramfs: wrong magic
FAT: unable to read boot sector
isofs_read_super: bread failed, dev=09:00, iso_blknum=16, block=32
Kernel panic: VFS: Unable to mount root fs on 09:00

Further information:
I couldn't update to 7.2 because of a different error (invalid operand 0000, CPU type: 0 .... then dump of registers, then a kernel panic).

My machine has a AMD 1.2 GHz Athlon, 256 MBytes RAM, SIS motherboard and a DVD drive.

Any help would be appreciated - especially if it gets RH 7.3 installed !!

Noerr 05-24-2002 11:21 AM

What filesystem are you using in rh71. It looks like a fs problem. Redhat is using ext3 since 7.2 distro, but it shouldn't be any problem reading ext2 fs.
From my point of view, best upgrade is clean install. You copy /etc /home and any other custom data to a save partition and install fresh copy.

hairysocks 05-27-2002 02:11 PM

I'm using ext2.

Can you explain what you mean by a "save partition" - I just have a boot patition then root.

How will a clean install work anyway - the error occurs before it even gets to the point of trying to update or install anything, doesn't it?

Noerr 05-27-2002 03:09 PM

it may be something funny in your partition table + mbr. It looks like rh-installer can not read your ext2. Is your rh71 still working?

If you have spare disk try to copy your data to that disk, otherwise check what partitions you have (df) and try to move your data to another partitions if possible
then boot with rh73 i386 disk1 and goto linux rescue
and from there try to format your primary partions (/dev/hda1) (if not the only one)

let me know of your partitions and fs,

btw make sure you didn't forcibly shut down computer before upgrade.

3inchrash 07-14-2002 10:12 AM

I had the same problem
I had the same problem with my machine. I disabled power management in my bios to resolve the problem. Doesn't make much sense.

andrewlydon 09-03-2002 06:48 AM

I had the same problem. (Duron 1200, PCChips/SiS 630, Toshiba DVD, Maxtor 40GB).

And, yup, the easy solution is indeed to turn off Power Management in the BIOS. Heaven knows why!

Explanations, anyone?

BTW, I had already sucessfully installed W2K and also I tried booting RH7.0. The RH7.0 would have worked, so this is something new in 7.3 that is getting confused.

StopRob 09-05-2002 03:50 AM

Same problem with PCChips MB
I have a PCChips motherboard as well and I encountered this problem until I disabled the Power Management options. Thanks forthe tip! :)

dmcardle 09-23-2002 03:20 PM


I've got the exact same - generic 7.3 install Athlon 1800 XP ECS motherboard - no previous OS on hard disk.

I tried turning off Power Management in the BIOS but that doesn't work.

Someone (somewhere else) said that device 09:00 is for software RAID (md). I don't have and haven't selected RAID anywhere.

Any help appreciated.

Declan McArdle.

All times are GMT -5. The time now is 02:35 PM.