LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Newbie (http://www.linuxquestions.org/questions/forumdisplay.php?f=8)
-   -   Restoring X11 from backup-- HELP! (http://www.linuxquestions.org/questions/showthread.php?t=615730)

philwynk 01-23-2008 08:43 AM

Restoring X11 from backup-- HELP!
 
Hi, all,

I munged my X11 setup stupidly -- downloaded some libraries in an attempt to install a new movie player, then stopped when I realized it wanted to replace my entire X11 software. A day later, I rebooted... and the monitor went blank. Crap.

So, I've got a backup from a few days ago, when I upgraded to fedora 8. I figured out how to mount the dvd (another little adventure).

Now:

In addition to extracting from the tarball everything that has *X11* in the name, what will I need to extract to make this work?

I've already restored all the X11 stuff I could find (/usr/lib, /usr/share, /etc/X11, etc.) but when I try to boot up, X11 fails with signal 11, so all I get is the command prompt. If somebody could tell me where one configures X11 -- which directory, which files -- I might be able to figure this out for myself.

Thanks in advance.

Phil W.

philwynk 01-23-2008 11:47 AM

Never mind
 
Never mind. I restored from scratch.

This is Bullsh*t. I try to install a software package and have to reinstall the entire OS to recover? Linux is NOT READY FOR DISTRIBUTION. Sorry, folks, but as shitty as Microsoft is, it's WAY WAY better an environment for the individual user than this.

elliott678 01-23-2008 11:49 AM

PEBCAK, do it right and that doesn't happen. I could mess around with .dll's and kill Windows pretty damn fast, guess it isn't ready either.

philwynk 01-23-2008 12:14 PM

You don't have to mess around with dlls to install a freakin' movie player in Windows. The ones that come with the package works, and the system protects itself against stuff that steps on OS functions.

I've been in IT since 1979. I worked with UNIX for f***ing LIVING for the better part of 20 years. There's a reason professional organizations running Unix servers in computer room hand out Windows laptops to their employees -- it's the same reason I'm discovering now. Linux is not friendly enough for ordinary use; you need either a geek or a professional to maintain it properly for you.

Take your arrogant attitude and jam it in your CD drive, idiot.

elliott678 01-23-2008 12:18 PM

I don't have to mess around with libraries to install a video player either, "pacman -Sy totem xine-ui mplayer vlc" I just installed the 4 most popular video players, no hassle at all.

Wanna know what I do for a living? You would expect me to be in IT to run a Linux OS properly right? I am a mechanic/auto body man.

philwynk 01-23-2008 12:37 PM

Ok, let's look at what you just did.

"pacman -Sy totem xine-ui mplayer vlc"

[root@localhost]# which pacman
/usr/bin/which: no pacman in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/lib/ccache:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)

Nice. What's "pacman?" If I'm new to linux, where do I find it? How much do I have to read about it before I understand what "-Sy" does? How many other command line switches are there on pacman, and if I don't understand the 15-word explanation in "man," where do I go to find more information? I google pacman, and I find man pages for PKGBUILD(5), libalpm(3),makepkg(8), makepkg.conf(5), pacman(8), pacman.conf(5), repo-add(8). How many DOZENS of hours of reading am I in for, just to understand what "pacman" does and how to use it?

What's xine? How do I install it? It doesn't come with Fedora 8, if I want it I have to go out and find a repository. Which repository do I use, the i386 one for Fedora 5? the i586 one for Red Hat? I download the source, how do I know which library switches I need on the command line to compile it? I run the package installer, it tells me it can't resolve dependencies. I go to find the missing library, download it, and it can't resolve dependencies, too.

And so on.

There's a video player built into Windows, and it's not a bad one. It interoperates with Explorer right out of the box. If I want a different player, I can download Realplayer or Quicktime; no configuration required. Download, done, works. They're hogs, sure, but I don't need to know anything other than how to launch a browser and click on a button. Oh, and what OS version I'm running.

All I can say is, Jack, your job must be a lot easier than mine, 'cause I don't have the f***ing WEEKS to read all the crap I need to read in order to get to the place that I can issue a "simple" command line arg like what you suggested.

You're the reason most people think Linux guys have two heads.

elliott678 01-23-2008 12:45 PM

Fedora has a really nice package manager, the repositories that come with it are a little lacking though, they try to be truly free in every sense of the word, the livna repo may have what you are looking for though.


If you find it this difficult to learn something new, maybe you should use something you are familiar with. Linux is not for Windows users, it is for Linux users.

philwynk 01-23-2008 01:46 PM

Quote:

If you find it this difficult to learn something new, maybe you should use something you are familiar with. Linux is not for Windows users, it is for Linux users.
Yeah, I'm a real weakling there. I only learned CICS, Basic, VSAM, ISAM, TICA, TV, DG/ux, vi, PERL, TCL, awk, SQL, and the UNIX shell all by reading manuals, not to mention the 4 or 5 different word processors I've learned from scratch, the several dozen application programs, the file conversion utilities I wrote for moving print jobs between IBM mainframe spoolers and UNIX spoolers, etc. I guess Linux is too hard for me. You're smart, I'm dumb. You win.

I think the point is, you have to want to become an expert system administrator to be able to manage a Linux system, and that's not what's generally needed for a desktop tool. I'll become one eventually, 'cause I don't have the bucks for Mr. Gates, but I'd rather not spend the time.

Quote:

Fedora has a really nice package manager
Sure. yum. And using yum, I was able to install a command-line version of mplayer -- once I figured out which package name to type in ("yum install mplayer" doesn't cut it.) I even managed to get it to fire up automatically through firefox for a handful of file types. But then, trying to find a player that worked with the Totem front-end and downloading the wrong libraries is what got me into trouble one of the times I had to reinstall.

All this is interesting, but what I really need right now is a good backup strategy so the NEXT time I blow away X-windows by downloading the wrong library during one of my "simple" installs, I can recover. Got any suggestions? 'cause what I DON'T need is some arrogant putz telling me how stupid I am. Call me strange, but I just don't find that helpful.

elliott678 01-23-2008 02:17 PM

I would really like to know how you killed your X config by installing a library, when I know this, I would be able to tell you how to recover from it. This isn't something I have ever heard of happening, I have been doing this for 7 years, I have never done this. Really your only config file for X is /etc/X11/xorg.conf, unless you replaced that(installing a media player, I couldn't imagine why you would), you didn't hurt your config, you hurt something totally different. Tell me how you broke it, I'll tell you how to fix it.

Also, did you add the livna repository to yum? It allows you to add the non-free codecs really simply so totem would be able to handle most of your needs.

philwynk 01-23-2008 02:31 PM

I'm not entirely sure, because it didn't manifest right away.

What was going on was I was trying to install the mplayer plug-in for firefox, after installing the working command-line mplayer. I googled for it, because I haven't figured out a way yet to find the precise package names for what I'm trying to download. What I found directed me to download source. I downloaded the mplayer-plugin source, and it told me I need XFree86-devel and XFree-86 libs. I knocked around looking for those, and downloaded .rpms for those and for something called XFree-common. Eventually I got to a page explaining that what I'm doing is replacing my entire X-windows installation with a different version. I backed off and tried something different at that point, but I think it was too late by then -- I probably should have just continued. The next evening, I restarted the machine for another reason, and when the machine came up, the screen was blank. The machine was up -- I could browse to my blog site from another host -- but no display on the monitor.

After the minor nightmare with XFree libraries, but before the fatal reboot, I discovered that simply typing "yum install mplayerplug-in" (if I'm recalling correctly) found what it needed, and seemed to work.

What you might be able to help me with is, what's the best way to find out the package name you need yum (or pacman) to grab?

By the way, I did have livna's repository configured for yum -- before I had to reinstall this morning. Now I have to do it again. Grrr...

PS -- please explain "add the non-free codecs." What's a "codec," and what are the non-free ones that have to do with Totem? The Totem installed by default on the Gnome desktop says it's the Gstreamer version, but I wasn't able to find Gstreamer to load it.

elliott678 01-23-2008 02:34 PM

Adding it is really simple, just install the .rpm listed here: http://rpm.livna.org/rlowiki/

mplayerplug-in is in that repository, so there is another thing you don't have to mess with.

You could always use the GUI front end to yum, it is pretty self explanatory and allows you to search.


(pacman is the package manager for Arch, you didn't specify which distro you had, i was just demonstrating how simple it was for me)

Quote:

PS -- please explain "add the non-free codecs." What's a "codec," and what are the non-free ones that have to do with Totem? The Totem installed by default on the Gnome desktop says it's the Gstreamer version, but I wasn't able to find Gstreamer to load it.
You were being pretty vague, so I assumed you were trying to view a video you didn't have a codec for (codec means the same here as it does in Windows), the "bad" and the "ugly" plugins for Gstreamer are considered non-free, because they are kinda on shaky legal ground because of how they were made, they allow you to play proprietary stuff like .wmv's.


All times are GMT -5. The time now is 08:17 PM.