LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-19-2009, 01:28 AM   #1
sd9
Member
 
Registered: Apr 2009
Posts: 53

Rep: Reputation: 15
Restart not working for Fedora 8


I have a system with Windows XP and Fedora 8.
When I select the restart option in Windows XP, the system reboots.
But when I select the restart option in Fedora, it does the shutting down process (shows all the green 'ok' messages) and stops. It doesn't restart.

How do I get it to restart?
 
Old 06-19-2009, 03:48 AM   #2
twantrd
Senior Member
 
Registered: Nov 2002
Location: CA
Distribution: redhat 7.3
Posts: 1,440

Rep: Reputation: 52
I don't use X all that much but how about typing the command 'reboot' in terminal?

-twantrd
 
Old 06-19-2009, 04:12 AM   #3
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
This could be acpi issue. Try including acpi=force at the end of kernel line. Also try adding reboot=b there.
 
Old 06-21-2009, 11:04 PM   #4
sd9
Member
 
Registered: Apr 2009
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by linuxlover.chaitanya View Post
This could be acpi issue. Try including acpi=force at the end of kernel line. Also try adding reboot=b there.
Appreciate the replys, but I'm a newbie to Linux. May I know what you mean by 'end of kernel line'? Is it a file? Do I add the reboot=b to the same line?
Any chance of something going wrong after I use these options?
 
Old 06-22-2009, 12:17 AM   #5
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Ok You need to change those settings in the grub file. It is usually /boot/grub/grub.conf in F8. Open the file using text editor that you are comfortable with and add the options I told on the line where you see kernel.

Something like this
Code:
 kernel          /boot/vmlinuz-2.6.24-24-generic root=UUID=0ac1c898-a214-438c    -b603-791411e18b45 ro  splash acpi=force reboot=b
 
Old 06-22-2009, 11:27 PM   #6
sd9
Member
 
Registered: Apr 2009
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by linuxlover.chaitanya View Post
Ok You need to change those settings in the grub file. It is usually /boot/grub/grub.conf in F8. Open the file using text editor that you are comfortable with and add the options I told on the line where you see kernel.

Something like this
Code:
 kernel          /boot/vmlinuz-2.6.24-24-generic root=UUID=0ac1c898-a214-438c    -b603-791411e18b45 ro  splash acpi=force reboot=b
Hmm...thanks...added it to the grub.conf file, but while booting, an error is shown while processing that line: "Error 15: File not found"

When I type reboot at the terminal, the system does the standard shutting down procedure, displays a messate "Restarting system" and just freezes there. It doesn't restart. How do I get it to restart automatically every time?

Last edited by sd9; 06-22-2009 at 11:29 PM.
 
Old 06-23-2009, 12:41 AM   #7
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
No. You do not need to add the line to your grub.conf. You need to look for the line that is similar to what I gave and add the options there. Why not post your grub.conf here so that someone can help you out.
 
Old 06-23-2009, 12:48 AM   #8
sd9
Member
 
Registered: Apr 2009
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by linuxlover.chaitanya View Post
No. You do not need to add the line to your grub.conf. You need to look for the line that is similar to what I gave and add the options there. Why not post your grub.conf here so that someone can help you out.
here it is:
Code:
title Fedora (2.6.23.1-42.fc8)
        root (hd0,4)
        kernel /vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/ rhgb quiet
        initrd /initrd-2.6.23.1-42.fc8.img
 
Old 06-23-2009, 12:51 AM   #9
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Change your original
Code:
title Fedora (2.6.23.1-42.fc8)
        root (hd0,4)
        kernel /vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/ rhgb quiet
        initrd /initrd-2.6.23.1-42.fc8.img
TO
Code:
title Fedora (2.6.23.1-42.fc8)
        root (hd0,4)
        kernel /vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/ rhgb quiet acpi=force reboot=b
        initrd /initrd-2.6.23.1-42.fc8.img
 
1 members found this post helpful.
Old 06-23-2009, 05:14 AM   #10
sd9
Member
 
Registered: Apr 2009
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by linuxlover.chaitanya View Post
Change your original
Code:
title Fedora (2.6.23.1-42.fc8)
        root (hd0,4)
        kernel /vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/ rhgb quiet
        initrd /initrd-2.6.23.1-42.fc8.img
TO
Code:
title Fedora (2.6.23.1-42.fc8)
        root (hd0,4)
        kernel /vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/ rhgb quiet acpi=force reboot=b
        initrd /initrd-2.6.23.1-42.fc8.img
Woohoo! Thanks a lot! It works.
I tried removing the 'acpi=force' and it still works with just the 'reboot=b'.
 
Old 06-23-2009, 06:53 AM   #11
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Great to know that it works.
 
Old 06-23-2009, 06:56 AM   #12
BajomiEndre
LQ Newbie
 
Registered: Jun 2009
Posts: 3

Rep: Reputation: 0
have a system with Windows XP and Fedora 8
 
Old 06-23-2009, 07:16 AM   #13
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Quote:
Originally Posted by BajomiEndre View Post
have a system with Windows XP and Fedora 8
And what is your question? Anything you find related to this thread?
 
Old 01-08-2010, 03:13 AM   #14
sd9
Member
 
Registered: Apr 2009
Posts: 53

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by sd9 View Post
Woohoo! Thanks a lot! It works.
I tried removing the 'acpi=force' and it still works with just the 'reboot=b'.
Hey, I just realised that I should have left the "acpi=force" in place. It ensures that the system power's off automatically after shutdown.
 
Old 01-08-2010, 03:24 AM   #15
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Are you still on F8? Its high time you got yourself a newer version.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 10.1 working wireless interface fails to restart on bootup kmars Linux - Wireless Networking 1 12-13-2006 04:58 PM
apache+php not working after restart raduromeo Linux - Software 5 11-23-2005 06:16 AM
Ethernet card not working when '/etc/rc.d/init.d/network restart'. brynjarh Linux - Newbie 1 08-11-2004 12:17 PM
fedora restart with internet adit_sen Linux - Hardware 0 04-18-2004 07:05 AM
proftpd stoped working after restart alimharji Linux - Networking 4 03-11-2004 10:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration