LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Resolving Qt dependencies (https://www.linuxquestions.org/questions/linux-newbie-8/resolving-qt-dependencies-634411/)

grecotex 04-10-2008 09:26 AM

Resolving Qt dependencies
 
When checking dependencies I get a message of Qt >= qt3.3 not found. I was told that I needed to set env QTDIR to where my qt libraries are. This does not seem to work either. Someone has suggested that I need the qt dev env to build and not just the binaries. Does this make sense and where and how to I accomplish this?

Agrouf 04-10-2008 09:31 AM

Yes it does make sense and where and how you accomplish this is dependant on your distro.
What is the distro you use?

grecotex 04-11-2008 12:45 AM

qt-devel solved the problem
 
My distro is Fedora Core 8. I did not have the qt-devel installed nor the paths to the lib and include files. I used yum install to get the development environment then I added the path information. This solved the problem. The original error message stumped me because it just indicated that I did not have the qt3.3 libs yet I definitely had the libs. Thanks for responded.

Agrouf 04-11-2008 03:24 AM

great! congrats!


All times are GMT -5. The time now is 10:37 AM.