LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-19-2007, 01:13 PM   #1
megha6788
Member
 
Registered: Oct 2007
Posts: 62

Rep: Reputation: 15
Unhappy No Video Bios Modes For Chosen Depth


heyy.......i hv encountered a strange problem....i cannot install fedora 7.0 using graphical mode..if i do so it gives an error like X SERVER failed....so i had to do all the installation part in text mode.. i created partitions n the packages installation part was over but now when i start my pc.m prompted for entering a localhost username and password , after providing that i mnt driven to fedora desktop but instead i get a prompt like [root@localhost~]#...on the same black screen....i tried with startx command and init 5 in this prompt but the log gave a result that there was error like "NO VIDEO BIOS MODES FOR CHOSEN DEPTH"..what should i do now???? i don't have any idea for how should i enter GUI ....plzzzzzz help experts!!!
 
Old 10-19-2007, 01:25 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Sounds like you may have an nvidia or Ati graphics interface, solutions have been posted many many times here in the Fedora Forum; http://www.linuxquestions.org/questions/fedora-35/ in fact is is a 'sticky' and at the top of the forum.
 
Old 10-19-2007, 01:32 PM   #3
kryptobs2000
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 306

Rep: Reputation: 30
Your xorg.conf is setup wrong. The error that you are getting, I think, means that your trying to start the xserver with a resolution that your videocard/monitor/drivers cannot support.

To fix this go log in as root and type vi /etx/X11/xorg.conf. This will open up the xorg.conf file so you can edit it. I'm assuming you won't know how to use vi either, but all you need to know for now is that there are two modes. A command mode (what you start in) and a edit mode (where you type shit). to get to edit mode just hi 'i' and to get back to command mode just hit esc.

Now navigate through the file towards the bottom and you will see a section with resolutions in it. Under the one that is for 24 bit color put the resolutions that your monitor/videocard will support. The 1st one(farthest to the left) is the one that the xserver will try to start in.

You also may need to change your horizontal and verticle sync values. I don't remember what this looks like off hand but it's around there somewhere. It should I believe be two seperate lines, one for horizontal and one for verticle, and they will be in ranges with one decimal place if I remember correctly. Look up your monitor online if you don't already know and change these values.

Finally to save the file go into command mode (hit esc), and type either :wq! (including the :, this tells vi you are entering a command) or hold shit and press Z twice. Now try and startx again.

If this still doesn't work please post your /var/log/xorg.0.log(I think this is the right name) and we can look at it. Also what kind of videocard do you have? Maybe you don't have the appropriate drivers installed.
 
Old 10-20-2007, 09:43 AM   #4
megha6788
Member
 
Registered: Oct 2007
Posts: 62

Original Poster
Rep: Reputation: 15
In the username section i entered root, then my password...i got the usual localhost@root# prompt i entered there vi/etx/X11/xorg.conf as u said but it showed an error file not found!!!! how come thats possible i think installation part is ok....i created 3 partitions
/boot -200mb
/ -4000mb
swap -1000mb

nothings wrong wid that i suppose!!!!
whats wrong then???
 
Old 10-20-2007, 10:23 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
There was a typo---you want:
vi /etc/X11/xorg.conf (note also the space after vi)

If you are not familiar with vi, you might find nano a bit easier.
 
Old 10-20-2007, 11:22 AM   #6
kryptobs2000
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 306

Rep: Reputation: 30
haha, sorry about that I should have reread my post. Also if you didn't know you can hit tab for auto-completion of commands. for instance if you type /et then hit tab it would change it to /etc/ since etc is the only file or directory that starts with /et
 
Old 10-20-2007, 12:59 PM   #7
megha6788
Member
 
Registered: Oct 2007
Posts: 62

Original Poster
Rep: Reputation: 15
okay now thats what i did type actually in [root@localhost~]#
cd /etc
cd X11
nano xorg.conf

i donno what to edit there i get sum section display
i'll tell u bout screen layout
identifier "screen0"
device "videocard0"
defaultdepth 24
subsection "display"
viewport 0 0
depth 24
.....then at the end i got some options like ^v i donno how to use em...did'nt edited nything till now bcoz i donno what to edit
if this needs my monitor config i can give
do tell what to do plzz!!!
 
Old 10-20-2007, 01:15 PM   #8
kryptobs2000
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 306

Rep: Reputation: 30
Quote:
Originally Posted by megha6788 View Post
okay now thats what i did type actually in [root@localhost~]#
cd /etc
cd X11
nano xorg.conf

i donno what to edit there i get sum section display
i'll tell u bout screen layout
identifier "screen0"
device "videocard0"
defaultdepth 24
subsection "display"
viewport 0 0
depth 24
.....then at the end i got some options like ^v i donno how to use em...did'nt edited nything till now bcoz i donno what to edit
if this needs my monitor config i can give
do tell what to do plzz!!!
ok that's where you need to look. Under the subsection "display" you need to add the following line:

Code:
Modes    "1280x960" "1024x768" "800x600"
That will tell the xserver what videomodes you want to start in. Change those to ones you want/can support though. And like I said earlier, it reads from the left to the right, so it will use the one farthest to the left initially. Here's what my xorg.conf looks like for the screen section if that gives you a better picture:

Code:
Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1280x1024" "1024x768" "800x600" "640x480" "320x240"
        EndSubSection
EndSection
you may also need to find the monitor section and change it as well, it will look like this:

Code:
Section "Monitor"
        Identifier   "My Monitor"
        HorizSync    31.5 - 50.0
        VertRefresh  40.0 - 90.0
EndSection
 
Old 10-20-2007, 01:36 PM   #9
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
For a complete description of the xorg.conf file, do "man xorg.conf". The same document is available here.

As already stated, you need your monitor specs--particularly the horiz and vertical sync frequencies.

Did you look at the link supplied by Lenard?

Here is a very minimal subset of my xorg.conf (just the parts relating to card, monitor, and screen:

Code:
Section "Monitor"
    Identifier "monitor1"
    VendorName "Viewsonic"
    ModelName "VP2030b"
    HorizSync 24-92
    VertRefresh 50-85
EndSection

Section "Device"
    Identifier "device1"
    VendorName "ATI Technologies Inc."
    BoardName "ATI Radeon"
    Driver "ati"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    Subsection "Display"
        Depth 24
        Modes "1600x1200"
    EndSubsection
EndSection
To the extent I understand it, you only need the correct frequencies and one mode that your monitor will support. Interestingly, with this setup, the GUI display control panel still shows a bunch of other modes. I think these are what is called the "standard VESA modes". (I'm still learning...)

Note also that vendor names, model #s, etc. are not required.
 
Old 10-20-2007, 02:11 PM   #10
megha6788
Member
 
Registered: Oct 2007
Posts: 62

Original Poster
Rep: Reputation: 15
section "serverlayout"
identifier "default layout"
screen 0 "screen" 0 0
input device "keyboard 0" "core keyboard"
endsection

section "input device"
identifier "keyboard0"
driver "kbd"
option "xkbdmodel" "pc105"
option "xkblayout" "us"
endsection

section "device"
identifier "videocard0"
driver "i810"
endsection

section "screen"
identifier "screen0"
device "videocard0"
defaultdepth 24
subsection "display"
viewport 0 0
depth 24
endsubsection

endsection



thats wat i saw when i did nano xorg.conf
i added one thing Modes to subsection display part
edited it to
subsection "display"
viewport 0 0
depth 24
Modes "800x600" "1024x768" "1152x864" "640x480"
endsubsection
endsection

and i saved that to xorg.conf....[note i've used ex symbol on keyboard bcoz we don hav a multiplic sign for tat resolution part...hope that is okay]
but now when i startx i get an errorfatal server error
caught signal 11 server aborting
XIO :fatal IO error 104(connection reset by peer) on X server ":0.0"
after 0 requests(0 known processed) with 0 events remaining

i hvnt yet made ny changes wid monitor part its not displayed actually using nano xconf.org
thats my monitor ratings i found using astro32!!

viewable size 13.8"
aspect ratio 4.3
horizontal size 28sm
vertical size 21sm
vertical freq 50-120hz
horizontal freq 30-55 khz
supported modes
mode1 640x480 @60hz[vga]
mode2 640x480 @75hz[vesa]
mode3 800x600 @60hz[vesa]
mode4 640x480 @60hz
mode5 640x480 @85hz
mode6 800x600 @85hz
mode7 1024x768 @60hz
mode8 1152x864 @60hz

i hvnt still provide sum other details like edid version n others...if sum specific data still remaining do tell....now i think i should get what exactly to edit!!!
thanks for ur previous attempts!! waiting for suggestions....
 
Old 10-20-2007, 03:24 PM   #11
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Your xorg.conf does not appear to have a Monitor section. Also, the Screen section has to have "monitor" as one of its entries.

Look at the example I supplied.
 
Old 10-20-2007, 04:02 PM   #12
kryptobs2000
Member
 
Registered: Dec 2003
Distribution: Slackware
Posts: 306

Rep: Reputation: 30
Here, add this to your xorg.conf:

Code:
Section "Monitor"
    Identifier "monitor0"
    HorizSync 30.0 - 55.0
    VertRefresh 50.0 - 120.0
EndSection
And then under the Screen section add the line: Monitor "monitor0"
 
Old 10-20-2007, 06:11 PM   #13
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
The command for fedora 7 to set or reset the xorg.conf file is;

system-config-display --reconfig --set-depth=24 --set-resolution=1024x768 --set-driver=i810

No vi, no nano, no editing needed this will write a new /etc/X11/xorg.conf file. For additional options use;

system-config-display --help

and read: info system-config-display
 
Old 10-21-2007, 03:46 AM   #14
megha6788
Member
 
Registered: Oct 2007
Posts: 62

Original Poster
Rep: Reputation: 15
okay i m done with changing monitor settings n also doin tat system-config-display
about monitor settings changing in xorg.conf.....it did'nt worked still it was no use
then that system-config-display command gave an error sayin" COULDNOT START X SERVER, TRYIN WITH FRESH CONFIGURATION , ERROR FAILED TO START X SERVER.
n again that root@localhost# prompt left
i have read something about 915resolution
check this out!!!
http://www.geocities.com/stomljen/
i've downloaded the file frm this on my xp.. my documents
i need to mount n install it in linux that would change my system file .....i donno nything about mounting...plzz read it n tell if mounting would work....n tell me in detail how to do that????
thanks..
 
Old 10-21-2007, 09:13 AM   #15
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
One you state you have Fedora 7 (from your first post), so why follow directions for a different distrabution???

Second, installing the 915 resolution packages is done by typing something like;

yum install 915resolution

Sorry, but the Red Hat family (which fedora is part of) does not support the NTFS filesystem 'out of the box', for this you need to do something like; yum install ntfs-3g

Then you can mount the ntfs partition by typing something like;

mkdir /mnt/Windows (you need someplace to mount the partition to)
mount -t auto /dev/sda1 /media/Windows

Then one can add a line entry to the /etc/fstab file which simplifies this, example below;
Code:
/dev/sda1		/media/Windows		ntfs-3g auto,users,uid=0,gid=500,umask=000,rw	0 0
You may want to bookmark:

http://docs.fedoraproject.org/
http://www.fedorafaq.org/
http://www.gagme.com/greg/linux/f7-tips.php

.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Resolution Problem on 6.06 broknindarkagain Ubuntu 4 07-13-2006 11:21 PM
X Resolution problem henkelarsson12 *BSD 3 06-11-2006 09:41 AM
Problem about rh 9.0 resolution TiCkO Linux - Newbie 3 12-04-2003 06:08 PM
Problem in Resolution brain_linux30 Linux - Newbie 4 10-11-2003 03:18 AM
Resolution problem JunLitsu Linux - Software 0 06-04-2003 11:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration