LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-30-2006, 09:52 PM   #1
ryan944299
LQ Newbie
 
Registered: Dec 2006
Location: Pennsylvania
Posts: 14

Rep: Reputation: 0
resolution only in 800x600 in pc linux


I recently set up my hard drive to dual boot PC Linux .92 and Windows XP. I must say it was a easy install, even for me who is a complete noob.

However for PC Linux, the resolution gives me two options, 800x600 and 1024x768, but only 800x600 works. Im used to 1024x768 from Windows and when I set display to that it has it split. When I say split I mean the left side of the display is on the right side of the monitor, and the right side is wrapped around to the left side of the monitor. How can I fix this?

My video is onboard on a Asus A8N32-SLI Deluxe, if that helps any. I have not changed any settings or messed with the kernel for anything. Im too much of a noob to even now how to do that. I ask that when you do respond please answer in very simple terms so a real noob like me can understand them. Thanks
 
Old 12-30-2006, 10:36 PM   #2
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
Don't know why it's doing that, but often that type problem can be fixed at the monitor. Try looking if there are menu buttons on your computer monitor. Look around the menu and there's often a way too slide the screen back and forth in that little menu. Try just sliding it back that way. Not the greatest, most elegant solution, but it might work.
 
Old 12-30-2006, 10:47 PM   #3
ryan944299
LQ Newbie
 
Registered: Dec 2006
Location: Pennsylvania
Posts: 14

Original Poster
Rep: Reputation: 0
Oh yeah my bad I forgot to mention that yes my monitor does infact have auto adjust and other settings. I already tried that and it does not solve the problem.
 
Old 12-30-2006, 10:48 PM   #4
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 14.2 Solus
Posts: 2,264

Rep: Reputation: 51
Check the horizontal and vertical frequencies for your monitor and check that against what is in your /etc/X11/xorg.conf file.
 
Old 12-30-2006, 11:01 PM   #5
ryan944299
LQ Newbie
 
Registered: Dec 2006
Location: Pennsylvania
Posts: 14

Original Poster
Rep: Reputation: 0
I checked that file and it has the horizontal freq. correct, it does not have vertical freq. in it.

Whoops I screwed up with information again. I was zoning out and didnt realize in the opening post that I said my video was onboard, its not its a nvidia 6800.

Last edited by ryan944299; 12-30-2006 at 11:07 PM.
 
Old 12-30-2006, 11:24 PM   #6
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
Which monitor do you have (vertical freq and horizontal freq are also fine)?
Please post the sections device, monitor and screen in your X configuration file.

Last edited by Wim Sturkenboom; 12-30-2006 at 11:26 PM.
 
Old 12-31-2006, 10:00 AM   #7
ryan944299
LQ Newbie
 
Registered: Dec 2006
Location: Pennsylvania
Posts: 14

Original Poster
Rep: Reputation: 0
Here are the different sections. The horizontal freq of my monitor is 31.5 to 60 so that part is correct. When I use 1024x768 it doesnt just wrap around my screen it also cuts off some of the display like the bottom menu bar.

Quote:
Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "NEC LCD1545V"
HorizSync 31.5-60
VertRefresh 55-75

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
Driver "fbdev"
VideoRam 4096
Option "DPMS" "false"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 15
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 16
Virtual 1024 768
EndSubsection

Subsection "Display"
Depth 24
Virtual 1024 768
EndSubsection
EndSection

Last edited by ryan944299; 12-31-2006 at 10:05 AM.
 
Old 12-31-2006, 10:08 AM   #8
raskin
Senior Member
 
Registered: Sep 2005
Location: France
Distribution: approximately NixOS (http://nixos.org)
Posts: 1,900

Rep: Reputation: 68
Try "vesa" instead of "fbdev" in 'Driver' ("Device" section). Also try running xvidtune as root with X running to change modelines to something sane.
 
Old 12-31-2006, 06:23 PM   #9
ryan944299
LQ Newbie
 
Registered: Dec 2006
Location: Pennsylvania
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks for all your help, I figured out what was causing it. I had PC Linux .92 on my hd at the time of this error so I booted to PC Linux .93 on the live cd and compared xorg.conf files and I saw a difference. PC Linux .93 lets me run in 1024x768 whereas .92 keeps me stuck in 800x600. The difference in the files which I assume was causing the resolution problem is below. This is what was in the .93 file under device, compare that to the device section from the .92 file above.

Quote:
Section "Device"
Identifier "device1"
VendorName "nVidia Corp."
BoardName "NVIDIA GeForce 6800 (generic)"
Driver "nv"
Option "DPMS"
EndSection
.93 has the vendor and board name info and also a different drive.
 
Old 12-31-2006, 10:02 PM   #10
gdivens51
Member
 
Registered: Aug 2003
Location: Asheville,NC
Distribution: Vector
Posts: 58

Rep: Reputation: 15
in the file u posted i noticed in the "Subsection "Display" that's 3rd from the bottom that it says - Depth 15

u guru's , is that right ?

seems like it should be 16, 24, etc
 
Old 12-31-2006, 10:49 PM   #11
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
15 is allowed. And it is more than likely not used as the defaultdepth is set to 16.
 
Old 01-01-2007, 02:41 AM   #12
rakeyry
LQ Newbie
 
Registered: Apr 2006
Distribution: Gentoo
Posts: 8

Rep: Reputation: 0
Post your /etc/X11/xorg.conf

What I think might be the problem is you need to find the line that looks like

Code:
Option      "CRT2Position" "RightOf"
And if it is "RightOf" change it to "Leftof" and vice-versa
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get a better resolution than 800X600 on debian bharath144 Linux - General 4 03-12-2006 10:23 AM
NEWBIE: Resolution still stuck at 800x600 sabkaraja MEPIS 3 11-22-2005 09:56 PM
screen resolution 800x600 chocloman Slackware 4 03-19-2005 09:41 AM
The X window is running only in 800x600 resolution abbasali Linux - Hardware 4 04-20-2004 01:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration